System freezes possibly linked to CPU Soft lockup and NVIDIA module

On my new desktop (AMD Ryzen 9 5900X, GeForce RTX 3070, Asus TUF X570-Plus, latest Archlinux + Gnome), at random times, the image on screen freezes and the system becomes unresponsive. If I look at the last messages in my journalctl I see the following:

May 14 16:09:19 jackdesk kernel: watchdog: BUG: soft lockup - CPU#7 stuck for 23s! [swapper/7:0]
May 14 16:09:19 jackdesk kernel: Modules linked in: tun xt_nat xt_tcpudp veth xt_conntrack xt_MASQUERADE nf_conntrack_netlink nfnetlink xt_addrty>
May 14 16:09:19 jackdesk kernel:  sysimgblt libphy fb_sys_fops i2c_piix4 soundcore wmi pinctrl_amd mac_hid acpi_cpufreq vboxnetflt(OE) vboxnetadp>
May 14 16:09:19 jackdesk kernel: CPU: 7 PID: 0 Comm: swapper/7 Tainted: P           OE     5.12.2-arch1-1 #1
May 14 16:09:19 jackdesk kernel: Hardware name: System manufacturer System Product Name/TUF GAMING X570-PLUS, BIOS 3801 04/07/2021
May 14 16:09:19 jackdesk kernel: RIP: 0010:_nv009854rm+0x102/0x480 [nvidia]
May 14 16:09:19 jackdesk kernel: Code: 00 4d 8d 84 32 70 02 00 00 41 d3 e1 44 85 8b 90 02 00 00 0f 85 0f 02 00 00 48 8b 7d 00 e8 76 56 3a 00 48 8>
May 14 16:09:19 jackdesk kernel: RSP: 0018:ffffb8e780418ac0 EFLAGS: 00000206
May 14 16:09:19 jackdesk kernel: RAX: 00001028f46ec556 RBX: ffff96f9159eec08 RCX: 0000000225c17d03
May 14 16:09:19 jackdesk kernel: RDX: 0000000000004568 RSI: 0000000000000000 RDI: 0000000000991f0e
May 14 16:09:19 jackdesk kernel: RBP: ffff96f91614db40 R08: 00026c252649310a R09: ffffffffc1241010
May 14 16:09:19 jackdesk kernel: R10: ffffb8e78614bf50 R11: ffffb8e78614c39c R12: ffff96f910b10008
May 14 16:09:19 jackdesk kernel: R13: ffffb8e78614bf74 R14: ffffb8e78614bf70 R15: ffff96f91ddd0008
May 14 16:09:19 jackdesk kernel: FS:  0000000000000000(0000) GS:ffff9707eebc0000(0000) knlGS:0000000000000000
May 14 16:09:19 jackdesk kernel: CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
May 14 16:09:19 jackdesk kernel: CR2: 00000000042cc000 CR3: 00000001b08a2000 CR4: 0000000000750ee0
May 14 16:09:19 jackdesk kernel: PKRU: 55555554
May 14 16:09:19 jackdesk kernel: Call Trace:
May 14 16:09:19 jackdesk kernel:  <IRQ>
May 14 16:09:19 jackdesk kernel:  ? _nv033182rm+0xce/0x160 [nvidia]
May 14 16:09:19 jackdesk kernel:  ? _nv034604rm+0x43e/0x450 [nvidia]
May 14 16:09:19 jackdesk kernel:  ? _nv034838rm+0x7e4/0xe70 [nvidia]
May 14 16:09:19 jackdesk kernel:  ? _nv034881rm+0x2b0/0x340 [nvidia]
May 14 16:09:19 jackdesk kernel:  ? _nv028926rm+0x726/0xe70 [nvidia]
May 14 16:09:19 jackdesk kernel:  ? _nv028930rm+0x40d/0x4f0 [nvidia]

It seems related to NVIDIA.
Please find attached also an nvidia-bug-report run on the subsequent boot. Do you have any suggestions to offer on how to further debug and possibly solve this issue? I cannot use my computer reliably for long periods due to this problem.
Thanks a lot!
nvidia-bug-report.log.gz (316.5 KB)