fedora optimus GeForce 940MX system freezes

system freezes continuously.
hangs for five seconds, freezes. then continues to work. it hangs randomly.

sorry for my bad eng.
nvidia-bug-report.log.gz (54.2 KB)

Nothing unusual in the logs but the Xorg logs are missing. Please run

sudo journalctl -b0 --no-pager _COMM=gdm-x-session >xorg.log

and attach the output file.

tank you for the answer

xorg.log (160 KB)

The setup looks fine, yet you’re running into

May 02 20:08:09 fedora30 /usr/libexec/gdm-x-session[7112]: nvLock: client timed out, taking the lock
May 02 20:36:44 fedora30 /usr/libexec/gdm-x-session[7112]: nvLock: client timed out, taking the lock

meaning freezes. Is this only appearing when nvidia.modeset=1 kernel parameter is added, aka prime sync enabled? Did you try with an earlier driver e.g. the 390 legacy?

When prime sync is activated, it is freezing.
It is clean installation. system is new.
I’m having the same problem with all distro… I tried all of them. same problem.
fedora 30 nvidia 418.56 running now
I didn’t build anything before that.

Is there a solution to this?

sorry for my bad eng.

The underlying problem is currently unclear to me so finding a solution is difficult.
Since you already tried different distros, did you also try one without Gnome, e.g. xfce? Which distros did you try so far?

I have the suspicion this might be a Gnome bug: https://bbs.archlinux.org/viewtopic.php?id=245468

kde and gnome tried. I don’t like xfce. I’ve never used.

kde neon, fedora, ubuntu, antergos, arch linux, manjaro pop os, kubuntu vs vs… I’ve tried, same problem.

When I try on kde, it freezes when I press the alt+tab keys.
freezes when running animations.

am I the only problem with this?

Doing some googling turns out that you’re not the only one but AFAIK the first one hitting this forum, so this seems to be something new, only occuring since some weeks.
Other threads seem to point towards kernel 5.0, tried downgrading to a 4.19 lts kernel?

I’ve installed 4.19 the problem continues. unfortunately not recovered

kernel 4.19.38 I tried the same problem continues

finally solved.
debian 10 buster testing it works smoothly.
kernel 4.19.0-4
nvidia-driver 410.104

Is the problem solved in kernel 5.1