Team Fortress 2 crashing after joining a game on Fedora 18 with latest drivers for 8600M GT

Well, first I reported the issue to Valve on GitHub (https://github.com/ValveSoftware/steam-for-linux/issues/2540) and after a few answers, gdrewb-valve (from Valve, of course) said that this error (generated by Steam):

Fri May 31 20:21:28 2013 GMT: file ‘’/tmp/dumps/crash_20130531172117_1.dmp’’, upload yes: ‘‘CrashID=bp-5d92f215-713f-46a2-af59-379112130531’’

was “entirely inside of the NVIDIA OpenGL driver” and I had to report it to NVIDIA. Okay, so here I am. After reading about reporting issues here, I got the bug report files and I’m going to attach it here.
This is about the Xorg: http://paste.fedoraproject.org/15957/70061484/

Describing the issue itself, I can’t play TF2 because every time I try to join a game, it simply crashes. By the way I wanted to know if my installation was done right (I had to do it manually inside init 3, akmod said something like nvidia was not available, can’t remember it exactly).
(PS: please tell me if you can see my attachments, because here it doesn’t show them some times)
nvidia-bug-report.log.gz (75 KB)
nvidia-installer.log (85 KB)

Hey what is this? An error just happened and I saw this in the logs:

So…?

Does this problem still occur with 319.23?

Hmmm I gotta check that, because I didn’t test it anymore. I’ll see if I can do it today, but it’s hard as I had to install it manually (on init 3).

The download of that version is not available on the official site (I still have the latest driver installed). Will it be available if I install with RPM Fusion (if only it works now… >_<)?

Uninstalled NVidia driver and re-installed it with RPM Fusion and now the version is 304.88… >_>
I’m gonna test if it still doesn’t work now

Now I’m getting these errors. The funny thing is that I have direct rendering activated. I don’t know what else I can do… ;/