Tensorflow-gpu Jetpack4.3 call error

Hi guys,

I freshly flashed my Jetson TX2 with Jetpack4.3, everything went well.

I tried to install Tensorflow-gpu 1.15 (the same version as my host) by following this documentation:
https://docs.nvidia.com/deeplearning/frameworks/install-tf-jetson-platform/index.html

Everything seem to work properly but when I want to call “import tensorflow” in python I have this issue poping up:
>>> import tensorflow as tf
2020-05-20 10:07:52.366699: W tensorflow/stream_executor/platform/default/dso_loader.cc:55] Could not load dynamic library ‘libcudart.so.10.0’; dlerror: libcudart.so.10.0: cannot open shared object file: No such file or directory; LD_LIBRARY_PATH: /usr/local/cuda-10.2/lib64:
2020-05-20 10:07:52.366764: I tensorflow/stream_executor/cuda/cudart_stub.cc:29] Ignore above cudart dlerror if you do not have a GPU set up on your machine.
2020-05-20 10:07:52.367045: W tensorflow/stream_executor/platform/default/dso_loader.cc:55] Could not load dynamic library ‘libcudart.so.10.0’; dlerror: libcudart.so.10.0: cannot open shared object file: No such file or directory; LD_LIBRARY_PATH: /usr/local/cuda-10.2/lib64:
2020-05-20 10:07:52.367081: I tensorflow/stream_executor/cuda/cudart_stub.cc:29] Ignore above cudart dlerror if you do not have a GPU set up on your machine.
Segmentation fault (core dumped)

I should precise that I’m using a virtualenv and I made the installation inside it.

The problem seems related to cudart library but it is installed:
(cv) nvidia@nvidia-desktop:~$ dpkg -l | grep cudart
ii cuda-cudart-10-2 10.2.89-1 arm64 CUDA Runtime native Libraries
ii cuda-cudart-dev-10-2 10.2.89-1 arm64 CUDA Runtime native dev links, headers

Any ideas where it can come from ?

Thanks

Hi,

It looks like your device is upgraded to JetPack4.4, which uses CUDA 10.2.
But the TF package is for JetPack4.3 with CUDA 10.0.

Please noticed that you will need to use the package built with the same JetPack version as you flashed.
Please find this topic for the corresponding package:

Thanks.

Hey,
you were right, I thought I flashed with 4.3 but it is 4.4 so it’s working, thanks !

Just a little question: it says that the library is now called tensorflow and no more tensorflow-gpu but I suppose it includes the gpu functionalities of the old library ?

Finally, a model created on my host with tensorflow 1.15 will it be readable by the library on Jetpack ?

Thanks again

Hi,

The packages are all built with GPU support.
So you can use GPU function without issue.

Our source is based from upstream TensorFlow with some essential patch for Jetson GPU, so it should be compatible to your model.

Thanks.

will you please tell me how you solve the above problem as i am getting the same error.

Hey rajesh,
as mentionned in the later answer, it was a problem of version of tensorflow. Nvidia provides a whl file for every version of TF matching the right version of Jetpack.

Just be carefull of that and it works well.