TensorFlow for Jetson TX2!

Our official release of TensorFlow for Jetson TX2!

Python 3.6+JetPack4.4

sudo apt-get install libhdf5-serial-dev hdf5-tools libhdf5-dev zlib1g-dev zip libjpeg8-dev liblapack-dev libblas-dev gfortran
sudo apt-get install python3-pip
sudo pip3 install -U pip
sudo pip3 install -U pip testresources setuptools numpy==1.16.1 future==0.17.1 mock==3.0.5 h5py==2.9.0 keras_preprocessing==1.0.5 keras_applications==1.0.8 gast==0.2.2 futures protobuf pybind11
# TF-2.x
$ sudo pip3 install --pre --extra-index-url https://developer.download.nvidia.com/compute/redist/jp/v44 tensorflow==2.2.0+nv20.8
# TF-1.15
$ sudo pip3 install --pre --extra-index-url https://developer.download.nvidia.com/compute/redist/jp/v44 ‘tensorflow<2’

Python 3.6+JetPack4.3

sudo apt-get install libhdf5-serial-dev hdf5-tools libhdf5-dev zlib1g-dev zip libjpeg8-dev
sudo apt-get install python3-pip
sudo pip3 install -U pip
sudo pip3 install -U numpy grpcio absl-py py-cpuinfo psutil portpicker six mock requests gast h5py astor termcolor protobuf keras-applications keras-preprocessing wrapt google-pasta
# TF-2.x
$ sudo pip3 install --pre --extra-index-url https://developer.download.nvidia.com/compute/redist/jp/v43 tensorflow==2.1.0+nv20.3
# TF-1.15
$ sudo pip3 install --pre --extra-index-url https://developer.download.nvidia.com/compute/redist/jp/v43 tensorflow==1.15.2+nv20.3

Python 3.6+JetPack4.2.1

sudo pip3 install --pre --extra-index-url https://developer.download.nvidia.com/compute/redist/jp/v42 tensorflow-gpu==1.14.0+nv19.10

Python 3.6+JetPack4.2

sudo pip3 install --pre --extra-index-url https://developer.download.nvidia.com/compute/redist/jp/v42 tensorflow-gpu

Python 3.5+JetPack3.3

sudo pip3 install --pre --extra-index-url https://developer.download.nvidia.com/compute/redist/jp/v33 tensorflow-gpu==1.14.0+nv19.7

Python 2.7+JetPack3.3

sudo pip install --pre --extra-index-url https://developer.download.nvidia.com/compute/redist/jp/v33 tensorflow-gpu==1.14.0+nv19.7

If you meet error when installing h5py, please run this command to solve the dependency:

sudo apt-get install libhdf5-serial-dev hdf5-tools

DL frameworks - https://developer.nvidia.com/deep-learning-frameworks
Download - https://developer.nvidia.com/embedded/downloads
Document - https://docs.nvidia.com/deeplearning/dgx/install-tf-jetsontx2/index.html

Hi,

Thank you for this.

Can it be installed inside a virtualenv ?
which version of tensorflow is it?
I have installed the version 1.10 with whl should i uninstall before install that one?

Thank you

Awesome!

This is TF 1.9.0 for TX2.
Thanks.

Hi,

Good news !!!
And for Jetson TX1 ?

Thank you

1 Like

We only have TX2 package currently.
Sorry for the inconvenience.

Thanks.

Are we able to call the python conversion for tensorrt to make a plan from the jetson now?

Hi,

TensorRT python API for Jetson is still not available.
But you can use the TF-TRT instead.

Thanks.

1 Like

wrong comment please ignore

Hi,

i try to install in python 3, in clear deploy.

after install pip in Tx2 using this:

but to install i want add --user in parameters

pip3 install --user --extra-index-url=https://developer.download.nvidia.com/compute/redist/jp33 tensorflow-gpu

if i don’t add this parameters receive any erros in permission to install numpy using this command.

I have installed tf for python 2.7 and i did had to use --user parameter to install it. So you should use --user parameter
PS: if you are planning to do training on tx2 i wouldn’t recommend it since Ram is a huge bottleneck and usually your training gets killed after a while
Good luck

@kilichzf

Thanks so much, i didn’t no about this problem with the Ram, i will work with the cloud.

I am getting a File does not exist error.

Fresh install of jetpack 3.3 and pip. Python 2.7

Any thoughts, please?

Problem solved. Typo in command string copied from elsewhere.

[b]Invalid requirement: ‘–extra-index-url=https://developer.download.nvidia.com/compute/redist/jp33’

It looks like a path. File ‘–extra-index-url=https://developer.download.nvidia.com/compute/redist/jp33’ does not exist.[/b]

!!!

Hi,

The path link is https://developer.download.nvidia.com/compute/redist/jp33/tensorflow-gpu/.

Please make sure you use the entire command in the comment#1.

pip install --extra-index-url=https://developer.download.nvidia.com/compute/redist/jp33 <b>tensorflow-gpu</b>

Thanks.

Hi, I received error message “TypeError: unsupported operand type(s) for -=: ‘Retry’ and ‘int’”, when running above command. Is it something related to the package?

Thank you in advance.

Hi, mk.ikhwan88

Type error is caused by the pip and proxy on your environment.
You can check this topic for more information:
https://stackoverflow.com/questions/37495375/python-pip-install-throws-typeerror-unsupported-operand-types-for-retry

You can solve it by simply up-grating the pip version or unsetting the proxy.

Thanks.

yeah thanks a lot. But after install it how to I use tensorflow. In command tool, where I must director to use it.