Tensor Flow Installation - Metafile Error

I am trying to install TensorFlow and so far have not had any success. My current setup is: Jetson TX2 dev kit, L4T R32.3.1 (Jetpack 43), python 3.6.9.

I used the instructions found through the Nvidia website ( Installing TensorFlow For Jetson Platform :: NVIDIA Deep Learning Frameworks Documentation ) and ( TensorFlow for Jetson TX2! ) and followed them as prescribed for installing the latest Tensorflow version for a specific JP version. I tried using both tensorflow and tensorflow-gpu for the package name but neither worked ( sudo pip3 install --extra-index-url https://developer.download.nvidia.com/compute/redist/jp/v43 tensorflow ).

The installation runs and the error I get is below. This specific error is for 2.1.0, but I get it for all versions related to JP V43. Is there anything I can do without changing my current version of JP/L4T?
Downloading https://developer.download.nvidia.com/compute/redist/jp/v43/tensorflow/tensorflow-2.1.0%2Bnv20.3-cp36-cp36m-linux_aarch64.whl (236.9 MB)
|████████████████████████████████| 236.9 MB 15.9 MB/s
WARNING: Discarding https://developer.download.nvidia.com/compute/redist/jp/v43/tensorflow/tensorflow-2.1.0%2Bnv20.3-cp36-cp36m-linux_aarch64.whl (from Index of /compute/redist/jp/v43/tensorflow). Requested tensorflow==2.1.0+nv20.3 from https://developer.download.nvidia.com/compute/redist/jp/v43/tensorflow/tensorflow-2.1.0%2Bnv20.3-cp36-cp36m-linux_aarch64.whl has inconsistent version: filename has ‘2.1.0+nv20.3’, but metadata has ‘2.1.0+nv20.3.tf2’
ERROR: Could not find a version that satisfies the requirement tensorflow==2.1.0+nv20.3
ERROR: No matching distribution found for tensorflow==2.1.0+nv20.3

Thank You!

Hi,

We are checking this issue internally.
Will update more information with you later.

Thanks.

Hi,

Confirmed that this issue can also be reproduced in our environment.
We are checking this with our internal team.
Will update more information with you later.

Thanks.

Thank you for the update!

Hi,

We found this issue is related to the newer pip3 tool.
Please downgrade pip3 to v20.2.4, and try it again.

$ sudo pip3 install -U pip==20.2.4
$ sudo pip3 install --pre --extra-index-url https://developer.download.nvidia.com/compute/redist/jp/v43 tensorflow

Thanks.

Hello - the installation got further than it has in the past, but ran into an error at the scipy wheel requirements. Is this also related to the pip tool? Were you able to get a complete and successful install? Error is copied below

sudo pip3 install --pre --extra-index-url https://developer.download.nvidia.com/compute/redist/jp/v43 tensorflow
^TWARNING: The directory ‘/home/jetson1/.cache/pip’ or its parent directory is not owned or is not writable by the current user. The cache has been disabled. Check the permissions and owner of that directory. If executing pip with sudo, you may want sudo’s -H flag.
Looking in indexes: https://pypi.org/simple, https://developer.download.nvidia.com/compute/redist/jp/v43
Collecting tensorflow
Downloading https://developer.download.nvidia.com/compute/redist/jp/v43/tensorflow/tensorflow-2.1.0%2Bnv20.3-cp36-cp36m-linux_aarch64.whl (236.9 MB)
|████████████████████████████████| 236.9 MB 22.0 MB/s
Requirement already satisfied: numpy<2.0,>=1.16.0 in /usr/local/lib/python3.6/dist-packages (from tensorflow) (1.19.5)
Requirement already satisfied: astor>=0.6.0 in /usr/local/lib/python3.6/dist-packages (from tensorflow) (0.8.1)
Collecting tensorboard<2.2.0,>=2.1.0
Downloading tensorboard-2.1.1-py3-none-any.whl (3.8 MB)
|████████████████████████████████| 3.8 MB 3.4 MB/s
Requirement already satisfied: termcolor>=1.1.0 in /usr/local/lib/python3.6/dist-packages (from tensorflow) (1.1.0)
Requirement already satisfied: wrapt>=1.11.1 in /usr/local/lib/python3.6/dist-packages (from tensorflow) (1.12.1)
Requirement already satisfied: wheel>=0.26; python_version >= “3” in /usr/local/lib/python3.6/dist-packages (from tensorflow) (0.36.2)
Requirement already satisfied: six>=1.12.0 in ./.local/lib/python3.6/site-packages (from tensorflow) (1.15.0)
Requirement already satisfied: absl-py>=0.7.0 in /usr/local/lib/python3.6/dist-packages (from tensorflow) (0.12.0)
Requirement already satisfied: google-pasta>=0.1.6 in /usr/local/lib/python3.6/dist-packages (from tensorflow) (0.2.0)
Requirement already satisfied: gast==0.2.2 in /usr/local/lib/python3.6/dist-packages (from tensorflow) (0.2.2)
Requirement already satisfied: opt-einsum>=2.3.2 in /usr/local/lib/python3.6/dist-packages (from tensorflow) (3.3.0)
Requirement already satisfied: keras-preprocessing>=1.1.0 in /usr/local/lib/python3.6/dist-packages (from tensorflow) (1.1.2)
Collecting scipy==1.4.1; python_version >= “3”
Downloading scipy-1.4.1.tar.gz (24.6 MB)
|████████████████████████████████| 24.6 MB 26.2 MB/s
Installing build dependencies … done
Getting requirements to build wheel … error
ERROR: Command errored out with exit status -4:
command: /usr/bin/python3 /usr/local/lib/python3.6/dist-packages/pip/_vendor/pep517/_in_process.py get_requires_for_build_wheel /tmp/tmpeav0h6l3
cwd: /tmp/pip-install-9eo0htxo/scipy
Complete output (0 lines):

ERROR: Command errored out with exit status -4: /usr/bin/python3 /usr/local/lib/python3.6/dist-packages/pip/_vendor/pep517/_in_process.py get_requires_for_build_wheel /tmp/tmpeav0h6l3 Check the logs for full command output.
WARNING: You are using pip version 20.2.4; however, version 21.0.1 is available.
You should consider upgrading via the ‘/usr/bin/python3 -m pip install --upgrade pip’ command.

Thank you!

Hi,

Could you specify the package version to see if it works?

$ sudo pip3 install scipy==1.14.1

Thanks.

Hi - I did try installing scipy 1.4.1 before tensorflow using “pip3…” and “sudo pip3…” to see if that would work and got the error pasted below. What is interesting is I was able to easily install scipy1.5.4 using “pip3 install --user scipy”. I was also able to install python 3.5.9 and could successfully install scipy 1.4.1 using “python3.5 -m pip install --user scipy==1.4.1”. However when I went to install tensorflow using your previous instruction after scipy1.4.1(python3.5) installed, I got the same error I posted on April 1 - tensorflow install error at scipy. I should mention that python 3.6.9 is my default and is what it looks like the tensorflow install is trying to use to install scipy1.4.1 as well. Thank you!

Collecting scipy==1.4.1
Using cached scipy-1.4.1.tar.gz (24.6 MB)
Installing build dependencies … done
Getting requirements to build wheel … error
ERROR: Command errored out with exit status -4:
command: /usr/bin/python3 /usr/local/lib/python3.6/dist-packages/pip/_vendor/pep517/_in_process.py get_requires_for_build_wheel /tmp/tmpgykdotch
cwd: /tmp/pip-install-y_sxlgyz/scipy_6a3a6c930f4b40a28d6868b91bd741dc
Complete output (0 lines):

WARNING: Discarding https://files.pythonhosted.org/packages/04/ab/e2eb3e3f90b9363040a3d885ccc5c79fe20c5b8a3caa8fe3bf47ff653260/scipy-1.4.1.tar.gz#sha256=dee1bbf3a6c8f73b6b218cb28eed8dd13347ea2f87d572ce19b289d6fd3fbc59 (from Links for scipy) (requires-python:>=3.5). Command errored out with exit status -4: /usr/bin/python3 /usr/local/lib/python3.6/dist-packages/pip/_vendor/pep517/_in_process.py get_requires_for_build_wheel /tmp/tmpgykdotch Check the logs for full command output.
ERROR: Could not find a version that satisfies the requirement scipy==1.4.1
ERROR: No matching distribution found for scipy==1.4.1

Hi,

We try to install it on a new flash device (JetPack4.3).
Here is the detailed steps for your reference:

$ sudo pip3 install -U pip==20.2.4
$ sudo apt-get install libhdf5-serial-dev hdf5-tools libhdf5-dev zlib1g-dev zip libjpeg8-
$ sudo ln -s /usr/include/locale.h /usr/include/xlocale.h
$ sudo pip3 install numpy grpcio absl-py py-cpuinfo psutil portpicker six mock requests gast h5py astor termcolor protobuf keras-applications keras-preprocessing wrapt google-pasta
$ sudo pip3 install --pre --extra-index-url https://developer.download.nvidia.com/compute/redist/jp/v43 tensorflow

Thanks.