Problem to Install TensorFlow<2.0 on jetson xavier

Hi friends,
I Try to install tensorflow<2.0 on my jetson xavier. I make venv with python3.8 and i run this command(from nvdia site):

sudo python3.8 -m pip install -U numpy grpcio absl-py py-cpuinfo psutil portpicker six mock requests gast h5py astor termcolor protobuf keras-applications keras-preprocessing wrapt google-pasta setuptools testresources

I get the following error:
Traceback (most recent call last):
File “”, line 1, in
File “/tmp/pip-build-gpvt_9i9/wrapt/setup.py”, line 33, in
setuptools.setup(
File “/usr/lib/python3/dist-packages/setuptools/init.py”, line 129, in setup
return distutils.core.setup(**attrs)
File “/usr/lib/python3.8/distutils/core.py”, line 121, in setup
dist.parse_config_files()
File “/usr/lib/python3/dist-packages/setuptools/dist.py”, line 493, in parse_config_files
parse_configuration(self, self.command_options,
File “/usr/lib/python3/dist-packages/setuptools/config.py”, line 106, in parse_configuration
meta.parse()
File “/usr/lib/python3/dist-packages/setuptools/config.py”, line 382, in parse
section_parser_method(section_options)
File “/usr/lib/python3/dist-packages/setuptools/config.py”, line 355, in parse_section
self[name] = value
File “/usr/lib/python3/dist-packages/setuptools/config.py”, line 173, in setitem
value = parser(value)
File “/usr/lib/python3/dist-packages/setuptools/config.py”, line 430, in _parse_version
version = self._parse_attr(value)
File “/usr/lib/python3/dist-packages/setuptools/config.py”, line 305, in _parse_attr
module = import_module(module_name)
File “/usr/lib/python3.8/importlib/init.py”, line 127, in import_module
return _bootstrap._gcd_import(name[level:], package, level)
File “”, line 1014, in _gcd_import
File “”, line 991, in _find_and_load
File “”, line 973, in _find_and_load_unlocked
ModuleNotFoundError: No module named ‘wrapt’

----------------------------------------

Command “python setup.py egg_info” failed with error code 1 in /tmp/pip-build-gpvt_9i9/wrapt/

Thanks to all the helpers this is my first time i try to run FastMot on my jetson.

Official Tensorflow packages provided by Nvidia are for Python 3.6 only.

Thanks for the quick reply, I try python 3.6 and still I have error:
ERROR: Command errored out with exit status 1:
command: /home/uvision/FastMOT/venv/bin/python3 /home/uvision/FastMOT/venv/lib/python3.6/site-packages/pip install --ignore-installed --no-user --prefix /tmp/pip-build-env-fbps5ce7/normal --no-warn-script-location --no-binary :none: --only-binary :none: -i Simple index – ‘Cython>=0.29.14; python_version >= “3.8”’ ‘Cython>=0.29; python_version < “3.8”’ ‘numpy==1.19.3; python_version >= “3.9”’ pkgconfig ‘numpy==1.17.5; python_version == “3.8”’ ‘numpy==1.12; python_version == “3.6”’ ‘numpy==1.14.5; python_version == “3.7”’
cwd: None
Complete output (2193 lines):
Ignoring Cython: markers ‘python_version >= “3.8”’ don’t match your environment
Ignoring numpy: markers ‘python_version >= “3.9”’ don’t match your environment
Ignoring numpy: markers ‘python_version == “3.8”’ don’t match your environment
Ignoring numpy: markers ‘python_version == “3.7”’ don’t match your environment
Collecting Cython>=0.29
Using cached Cython-0.29.24-cp36-cp36m-manylinux_2_17_aarch64.manylinux2014_aarch64.whl (1.9 MB)
Collecting pkgconfig
Downloading pkgconfig-1.5.5-py3-none-any.whl (6.7 kB)
Collecting numpy==1.12
Using cached numpy-1.12.0.zip (4.8 MB)
Preparing metadata (setup.py): started
Preparing metadata (setup.py): finished with status ‘done’
Using legacy ‘setup.py install’ for numpy, since package ‘wheel’ is not installed.
Installing collected packages: pkgconfig, numpy, Cython
Running setup.py install for numpy: started
Running setup.py install for numpy: still running…
Running setup.py install for numpy: still running…
Running setup.py install for numpy: finished with status ‘error’
ERROR: Command errored out with exit status 1:
command: /home/uvision/FastMOT/venv/bin/python3 -u -c ‘import io, os, sys, setuptools, tokenize; sys.argv[0] = ‘"’"’/tmp/pip-install-tpgj20pe/numpy_2e35d4e3ac34471abef67970888ffba7/setup.py’"’"’; file=’"’"’/tmp/pip-install-tpgj20pe/numpy_2e35d4e3ac34471abef67970888ffba7/setup.py’"’"’;f = getattr(tokenize, ‘"’"‘open’"’"’, open)(file) if os.path.exists(file) else io.StringIO(’"’"‘from setuptools import setup; setup()’"’"’);code = f.read().replace(’"’"’\r\n’"’"’, ‘"’"’\n’"’"’);f.close();exec(compile(code, file, ‘"’"‘exec’"’"’))’ install --record /tmp/pip-record-lsx3qzw2/install-record.txt --single-version-externally-managed --prefix /tmp/pip-build-env-fbps5ce7/normal --compile --install-headers /tmp/pip-build-env-fbps5ce7/normal/include/site/python3.6/numpy
cwd: /tmp/pip-install-tpgj20pe/numpy_2e35d4e3ac34471abef67970888ffba7/
Complete output (2169 lines):
Running from numpy source directory.

  Note: if you need reliable uninstall behavior, then install
  with pip instead of using `setup.py install`:

    - `pip install .`       (from a git repo or downloaded source
                             release)
    - `pip install numpy`   (last NumPy release on PyPi)


  blas_opt_info:
  blas_mkl_info:
    libraries mkl_rt not found in ['/home/uvision/FastMOT/venv/lib', '/usr/local/lib', '/usr/lib', '/usr/lib/aarch64-linux-gnu']
    NOT AVAILABLE

  blis_info:
    libraries blis not found in ['/home/uvision/FastMOT/venv/lib', '/usr/local/lib', '/usr/lib', '/usr/lib/aarch64-linux-gnu']
    NOT AVAILABLE

  openblas_info:
    libraries openblas not found in ['/home/uvision/FastMOT/venv/lib', '/usr/local/lib', '/usr/lib', '/usr/lib/aarch64-linux-gnu']
    NOT AVAILABLE

  atlas_3_10_blas_threads_info:
  Setting PTATLAS=ATLAS
    libraries tatlas not found in ['/home/uvision/FastMOT/venv/lib', '/usr/local/lib', '/usr/lib', '/usr/lib/aarch64-linux-gnu']
    NOT AVAILABLE

  atlas_3_10_blas_info:
    libraries satlas not found in ['/home/uvision/FastMOT/venv/lib', '/usr/local/lib', '/usr/lib', '/usr/lib/aarch64-linux-gnu']
    NOT AVAILABLE

  atlas_blas_threads_info:
  Setting PTATLAS=ATLAS
    libraries ptf77blas,ptcblas,atlas not found in ['/home/uvision/FastMOT/venv/lib', '/usr/local/lib', '/usr/lib', '/usr/lib/aarch64-linux-gnu']
    NOT AVAILABLE

  atlas_blas_info:
    libraries f77blas,cblas,atlas not found in ['/home/uvision/FastMOT/venv/lib', '/usr/local/lib', '/usr/lib', '/usr/lib/aarch64-linux-gnu']
    NOT AVAILABLE

  /tmp/pip-install-tpgj20pe/numpy_2e35d4e3ac34471abef67970888ffba7/numpy/distutils/system_info.py:572: UserWarning:
      Atlas (http://math-atlas.sourceforge.net/) libraries not found.
      Directories to search for the libraries can be specified in the
      numpy/distutils/site.cfg file (section [atlas]) or by setting
      the ATLAS environment variable.
    self.calc_info()
  blas_info:
  customize UnixCCompiler
  C compiler: aarch64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -g -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -fPIC

  creating /tmp/tmp67gqnmu_/tmp
  creating /tmp/tmp67gqnmu_/tmp/tmp67gqnmu_
  compile options: '-I/usr/local/include -I/usr/include -I/home/uvision/FastMOT/venv/include -c'
  aarch64-linux-gnu-gcc: /tmp/tmp67gqnmu_/source.c
  aarch64-linux-gnu-gcc -pthread /tmp/tmp67gqnmu_/tmp/tmp67gqnmu_/source.o -lcblas -o /tmp/tmp67gqnmu_/a.out
  /usr/bin/ld: cannot find -lcblas
  collect2: error: ld returned 1 exit status
  /usr/bin/ld: cannot find -lcblas
  collect2: error: ld returned 1 exit status
  aarch64-linux-gnu-gcc -pthread /tmp/tmp67gqnmu_/tmp/tmp67gqnmu_/source.o -lblas -o /tmp/tmp67gqnmu_/a.out
    FOUND:
      libraries = ['blas', 'blas']
      library_dirs = ['/usr/lib/aarch64-linux-gnu']
      language = c
      define_macros = [('HAVE_CBLAS', None)]

    FOUND:
      define_macros = [('NO_ATLAS_INFO', 1), ('HAVE_CBLAS', None)]
      libraries = ['blas', 'blas']
      library_dirs = ['/usr/lib/aarch64-linux-gnu']
      language = c

  /bin/sh: 1: svnversion: not found
  non-existing path in 'numpy/distutils': 'site.cfg'
  /bin/sh: 1: svnversion: not found
  F2PY Version 2
  lapack_opt_info:
  lapack_mkl_info:
    libraries mkl_rt not found in ['/home/uvision/FastMOT/venv/lib', '/usr/local/lib', '/usr/lib', '/usr/lib/aarch64-linux-gnu']
    NOT AVAILABLE

  openblas_lapack_info:
    libraries openblas not found in ['/home/uvision/FastMOT/venv/lib', '/usr/local/lib', '/usr/lib', '/usr/lib/aarch64-linux-gnu']
    NOT AVAILABLE

  atlas_3_10_threads_info:
  Setting PTATLAS=ATLAS
    libraries tatlas,tatlas not found in /home/uvision/FastMOT/venv/lib
    libraries lapack_atlas not found in /home/uvision/FastMOT/venv/lib
    libraries tatlas,tatlas not found in /usr/local/lib
    libraries lapack_atlas not found in /usr/local/lib
    libraries tatlas,tatlas not found in /usr/lib
    libraries lapack_atlas not found in /usr/lib
    libraries tatlas,tatlas not found in /usr/lib/aarch64-linux-gnu
    libraries lapack_atlas not found in /usr/lib/aarch64-linux-gnu
  <class 'numpy.distutils.system_info.atlas_3_10_threads_info'>
    NOT AVAILABLE

  atlas_3_10_info:
    libraries satlas,satlas not found in /home/uvision/FastMOT/venv/lib
    libraries lapack_atlas not found in /home/uvision/FastMOT/venv/lib
    libraries satlas,satlas not found in /usr/local/lib
    libraries lapack_atlas not found in /usr/local/lib
    libraries satlas,satlas not found in /usr/lib
    libraries lapack_atlas not found in /usr/lib
    libraries satlas,satlas not found in /usr/lib/aarch64-linux-gnu
    libraries lapack_atlas not found in /usr/lib/aarch64-linux-gnu
  <class 'numpy.distutils.system_info.atlas_3_10_info'>
    NOT AVAILABLE

  atlas_threads_info:
  Setting PTATLAS=ATLAS
    libraries ptf77blas,ptcblas,atlas not found in /home/uvision/FastMOT/venv/lib
    libraries lapack_atlas not found in /home/uvision/FastMOT/venv/lib
    libraries ptf77blas,ptcblas,atlas not found in /usr/local/lib
    libraries lapack_atlas not found in /usr/local/lib
    libraries ptf77blas,ptcblas,atlas not found in /usr/lib
    libraries lapack_atlas not found in /usr/lib
    libraries ptf77blas,ptcblas,atlas not found in /usr/lib/aarch64-linux-gnu
    libraries lapack_atlas not found in /usr/lib/aarch64-linux-gnu
  <class 'numpy.distutils.system_info.atlas_threads_info'>
    NOT AVAILABLE

  atlas_info:
    libraries f77blas,cblas,atlas not found in /home/uvision/FastMOT/venv/lib
    libraries lapack_atlas not found in /home/uvision/FastMOT/venv/lib
    libraries f77blas,cblas,atlas not found in /usr/local/lib
    libraries lapack_atlas not found in /usr/local/lib
    libraries f77blas,cblas,atlas not found in /usr/lib
    libraries lapack_atlas not found in /usr/lib
    libraries f77blas,cblas,atlas not found in /usr/lib/aarch64-linux-gnu
    libraries lapack_atlas not found in /usr/lib/aarch64-linux-gnu
  <class 'numpy.distutils.system_info.atlas_info'>
    NOT AVAILABLE

  lapack_info:
    FOUND:
      libraries = ['lapack', 'lapack']
      library_dirs = ['/usr/lib/aarch64-linux-gnu']
      language = f77

    FOUND:
      define_macros = [('NO_ATLAS_INFO', 1), ('HAVE_CBLAS', None)]
      libraries = ['lapack', 'lapack', 'blas', 'blas']
      library_dirs = ['/usr/lib/aarch64-linux-gnu']
      language = c

  /usr/lib/python3.6/distutils/dist.py:261: UserWarning: Unknown distribution option: 'define_macros'
    warnings.warn(msg)
  running install
  running build
  running config_cc
  unifing config_cc, config, build_clib, build_ext, build commands --compiler options
  running config_fc
  unifing config_fc, config, build_clib, build_ext, build commands --fcompiler options
  running build_src
  build_src
  building py_modules sources
  creating build
  creating build/src.linux-aarch64-3.6
  creating build/src.linux-aarch64-3.6/numpy
  creating build/src.linux-aarch64-3.6/numpy/distutils
  building library "npymath" sources
  customize Gnu95FCompiler
  Found executable /usr/bin/gfortran
  customize Gnu95FCompiler
  customize Gnu95FCompiler using config
  C compiler: aarch64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -g -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -fPIC

  compile options: '-Inumpy/core/src/private -Inumpy/core/src -Inumpy/core -Inumpy/core/src/npymath -Inumpy/core/src/multiarray -Inumpy/core/src/umath -Inumpy/core/src/npysort -I/home/uvision/FastMOT/venv/include -I/usr/include/python3.6m -c'
  aarch64-linux-gnu-gcc: _configtest.c
  aarch64-linux-gnu-gcc -pthread _configtest.o -o _configtest
  success!
  removing: _configtest.c _configtest.o _configtest
  C compiler: aarch64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -g -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -fPIC

  compile options: '-Inumpy/core/src/private -Inumpy/core/src -Inumpy/core -Inumpy/core/src/npymath -Inumpy/core/src/multiarray -Inumpy/core/src/umath -Inumpy/core/src/npysort -I/home/uvision/FastMOT/venv/include -I/usr/include/python3.6m -c'
  aarch64-linux-gnu-gcc: _configtest.c
  _configtest.c:1:5: warning: conflicting types for built-in function ‘exp’ [-Wbuiltin-declaration-mismatch]
   int exp (void);
       ^~~
  aarch64-linux-gnu-gcc -pthread _configtest.o -o _configtest
  _configtest.o: In function `main':
  /tmp/pip-install-tpgj20pe/numpy_2e35d4e3ac34471abef67970888ffba7/_configtest.c:6: undefined reference to `exp'
  collect2: error: ld returned 1 exit status
  _configtest.o: In function `main':
  /tmp/pip-install-tpgj20pe/numpy_2e35d4e3ac34471abef67970888ffba7/_configtest.c:6: undefined reference to `exp'
  collect2: error: ld returned 1 exit status
  failure.
  removing: _configtest.c _configtest.o
  C compiler: aarch64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -g -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -fPIC

  compile options: '-Inumpy/core/src/private -Inumpy/core/src -Inumpy/core -Inumpy/core/src/npymath -Inumpy/core/src/multiarray -Inumpy/core/src/umath -Inumpy/core/src/npysort -I/home/uvision/FastMOT/venv/include -I/usr/include/python3.6m -c'
  aarch64-linux-gnu-gcc: _configtest.c
  _configtest.c:1:5: warning: conflicting types for built-in function ‘exp’ [-Wbuiltin-declaration-mismatch]
   int exp (void);
       ^~~
  aarch64-linux-gnu-gcc -pthread _configtest.o -lm -o _configtest
  success!
  removing: _configtest.c _configtest.o _configtest
  creating build/src.linux-aarch64-3.6/numpy/core
  creating build/src.linux-aarch64-3.6/numpy/core/src
  creating build/src.linux-aarch64-3.6/numpy/core/src/npymath
  conv_template:> build/src.linux-aarch64-3.6/numpy/core/src/npymath/npy_math.c
  conv_template:> build/src.linux-aarch64-3.6/numpy/core/src/npymath/ieee754.c
  conv_template:> build/src.linux-aarch64-3.6/numpy/core/src/npymath/npy_math_complex.c
  building library "npysort" sources
  creating build/src.linux-aarch64-3.6/numpy/core/src/npysort
  conv_template:> build/src.linux-aarch64-3.6/numpy/core/src/npysort/quicksort.c
  conv_template:> build/src.linux-aarch64-3.6/numpy/core/src/npysort/mergesort.c
  conv_template:> build/src.linux-aarch64-3.6/numpy/core/src/npysort/heapsort.c
  creating build/src.linux-aarch64-3.6/numpy/core/src/private
  conv_template:> build/src.linux-aarch64-3.6/numpy/core/src/private/npy_partition.h
    adding 'build/src.linux-aarch64-3.6/numpy/core/src/private' to include_dirs.
  conv_template:> build/src.linux-aarch64-3.6/numpy/core/src/npysort/selection.c
  conv_template:> build/src.linux-aarch64-3.6/numpy/core/src/private/npy_binsearch.h
  conv_template:> build/src.linux-aarch64-3.6/numpy/core/src/npysort/binsearch.c
  None - nothing done with h_files = ['build/src.linux-aarch64-3.6/numpy/core/src/private/npy_partition.h', 'build/src.linux-aarch64-3.6/numpy/core/src/private/npy_binsearch.h']
  building extension "numpy.core._dummy" sources
  Generating build/src.linux-aarch64-3.6/numpy/core/include/numpy/config.h
  C compiler: aarch64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -g -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -fPIC

  compile options: '-Inumpy/core/src/private -Inumpy/core/src -Inumpy/core -Inumpy/core/src/npymath -Inumpy/core/src/multiarray -Inumpy/core/src/umath -Inumpy/core/src/npysort -I/home/uvision/FastMOT/venv/include -I/usr/include/python3.6m -c'
  aarch64-linux-gnu-gcc: _configtest.c
  success!
  removing: _configtest.c _configtest.o
  C compiler: aarch64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -g -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -fPIC

  compile options: '-Inumpy/core/src/private -Inumpy/core/src -Inumpy/core -Inumpy/core/src/npymath -Inumpy/core/src/multiarray -Inumpy/core/src/umath -Inumpy/core/src/npysort -I/home/uvision/FastMOT/venv/include -I/usr/include/python3.6m -c'
  aarch64-linux-gnu-gcc: _configtest.c
  success!
  removing: _configtest.c _configtest.o
  C compiler: aarch64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -g -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -fPIC

  compile options: '-Inumpy/core/src/private -Inumpy/core/src -Inumpy/core -Inumpy/core/src/npymath -Inumpy/core/src/multiarray -Inumpy/core/src/umath -Inumpy/core/src/npysort -I/home/uvision/FastMOT/venv/include -I/usr/include/python3.6m -c'
  aarch64-linux-gnu-gcc: _configtest.c
  _configtest.c:1:10: fatal error: sys/endian.h: No such file or directory
   #include <sys/endian.h>
            ^~~~~~~~~~~~~~
  compilation terminated.
  _configtest.c:1:10: fatal error: sys/endian.h: No such file or directory
   #include <sys/endian.h>
            ^~~~~~~~~~~~~~
  compilation terminated.
  failure.
  removing: _configtest.c _configtest.o
  C compiler: aarch64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -g -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -fPIC

  compile options: '-Inumpy/core/src/private -Inumpy/core/src -Inumpy/core -Inumpy/core/src/npymath -Inumpy/core/src/multiarray -Inumpy/core/src/umath -Inumpy/core/src/npysort -I/home/uvision/FastMOT/venv/include -I/usr/include/python3.6m -c'
  aarch64-linux-gnu-gcc: _configtest.c
  success!
  removing: _configtest.c _configtest.o
  C compiler: aarch64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -g -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -fPIC

  compile options: '-Inumpy/core/src/private -Inumpy/core/src -Inumpy/core -Inumpy/core/src/npymath -Inumpy/core/src/multiarray -Inumpy/core/src/umath -Inumpy/core/src/npysort -I/home/uvision/FastMOT/venv/include -I/usr/include/python3.6m -c'
  aarch64-linux-gnu-gcc: _configtest.c
  success!
  removing: _configtest.c _configtest.o
  C compiler: aarch64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -g -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -fPIC

and more…

Hi,

As dkreutz mentioned, we only provide the python 3.6 TensorFlow package.

Based on your output, the error is caused by some missing libraries.
Please check the dependencies and install them accordingly.

For example:

  openblas_info:
    libraries openblas not found in ['/home/uvision/FastMOT/venv/lib', '/usr/local/lib', '/usr/lib', '/usr/lib/aarch64-linux-gnu']
    NOT AVAILABLE

Then you can install it via the following command:

sudo apt-get update
sudo apt-get install -y build-essential libatlas-base-dev

Thanks.

Hi,
I show my pip venv list :
Package Version


absl-py 0.14.1
astor 0.8.1
astunparse 1.6.3
cupy 9.5.0
Cython 0.29.24
dataclasses 0.8
fastrlock 0.6
gast 0.3.3
google-pasta 0.2.0
grpcio 1.41.0
h5py 2.10.0
idna 3.2
importlib-metadata 4.8.1
Keras-Applications 1.0.8
Keras-Preprocessing 1.1.2
llvmlite 0.36.0
Markdown 3.3.4
numba 0.53.1
numpy 1.18.5
opt-einsum 3.3.0
pbr 5.6.0
pip 21.3
pkg_resources 0.0.0
protobuf 3.18.1
scipy 1.5.4
setuptools 58.2.0
six 1.16.0
tensorboard 1.15.0
tensorflow 1.15.5+nv21.9
tensorflow-estimator 1.15.1
termcolor 1.1.0
typing-extensions 3.10.0.2
urllib3 1.26.7
Werkzeug 2.0.2
wheel 0.37.0
wrapt 1.12.1
zipp 3.6.0

It’s see like tensorflow install on my venv.
bit when i try this command : ./scripts/install_jetson.sh
(From FastMOT Github GitHub - GeekAlexis/FastMOT: High-performance multiple object tracking based on YOLO, Deep SORT, and KLT 🚀)
I Get this error:
ERROR: Could not find a version that satisfies the requirement tensorflow==1.15.5+nv21.7 (from versions: none)
ERROR: No matching distribution found for tensorflow==1.15.5+nv21.7

Thanks to all the helpers.