TensorFlow 1.11.0 wheel with JetPack 3.3

TF-1.11.0rc1 for JetPack3.3 is updated !!
Python 2.7:
https://nvidia.box.com/v/JP33-TF1-11-0-py27-wTRT

Python 3.5:
https://nvidia.box.com/v/JP33-TF1-11-0-py35-wTRT


Our previous achieve for JetPack3.2:
Python 2.7:
r1.10.1: https://nvidia.box.com/v/TF1101-Py27-wTRT
r1.10 : https://nvidia.app.box.com/v/TF1100-Py27-wTRT
r1.9 : https://nvidia.box.com/v/TF190rc0-py27-wTRT
r1.8 : https://nvidia.box.com/v/TF180-Py27-wTRT
r1.7 : https://nvidia.box.com/v/TF170-py27-wTRT

Python 3.5:
r1.10.1: https://nvidia.box.com/v/TF1101-Py35-wTRT
r1.10 : https://nvidia.app.box.com/v/TF1100-Py35-wTRT
r1.9 : https://nvidia.box.com/v/TF190rc0-py35-wTRT
r1.8 : https://nvidia.box.com/v/TF180-Py35-wTRT
r1.7 : https://nvidia.box.com/v/TF170-py35-wTRT

Thanks : )

Hi thanks for the link.

This is the first time i am installing tensorflow from a .whl file. Would this install all the dependencies aswell?

Don’t worry I just installed it and worked straight away. Thanks for the wheel files. Much appreciated

I get this:

Exception:
Traceback (most recent call last):
File “/usr/local/lib/python2.7/dist-packages/pip/basecommand.py”, line 215, in main
status = self.run(options, args)
File “/usr/local/lib/python2.7/dist-packages/pip/commands/install.py”, line 324, in run
requirement_set.prepare_files(finder)
File “/usr/local/lib/python2.7/dist-packages/pip/req/req_set.py”, line 380, in prepare_files
ignore_dependencies=self.ignore_dependencies))
File “/usr/local/lib/python2.7/dist-packages/pip/req/req_set.py”, line 620, in _prepare_file
session=self.session, hashes=hashes)
File “/usr/local/lib/python2.7/dist-packages/pip/download.py”, line 821, in unpack_url
hashes=hashes
File “/usr/local/lib/python2.7/dist-packages/pip/download.py”, line 663, in unpack_http_url
unpack_file(from_path, location, content_type, link)
File “/usr/local/lib/python2.7/dist-packages/pip/utils/init.py”, line 599, in unpack_file
flatten=not filename.endswith(’.whl’)
File “/usr/local/lib/python2.7/dist-packages/pip/utils/init.py”, line 484, in unzip_file
zip = zipfile.ZipFile(zipfp, allowZip64=True)
File “/usr/lib/python2.7/zipfile.py”, line 770, in init
self._RealGetContents()
File “/usr/lib/python2.7/zipfile.py”, line 811, in _RealGetContents
raise BadZipfile, “File is not a zip file”
BadZipfile: File is not a zip file

Hi,

We have updated the wheel for both TX1 and TX2 GPU architecture.
Please give it a try.

Thanks.

As the first wheel worked for me, is it recommended i install this new wheel?

Hi,

The new wheel adds TX1 GPU architecture support.
For TX2 user, it is the same.

Thanks

Does this wheel file have Tensorflow TensorRT support, yet?

I had build tensorflow 1.7 with tensorRT support.

https://github.com/peterlee0127/tensorflow-nvJetson

here is patch for building tensorRT for Jetson.
https://github.com/tensorflow/tensorflow/pull/17394
https://github.com/tensorflow/tensorflow/pull/17409

Currently, these code already merge, but it’s not release within TF 1.7.

Very cool. Thanks!

@peterlee0127 Just curious when configuring for the tensorflow build, what was the path you specified for the TensorRT installation location?

Trying to install this with python 2.7.12 on TX2: “tensorflow-1.7.0rc1-cp27-cp27mu-linux_aarch64.whl is not a supported wheel on this platform.”

Granted, I’m a bit of a Python / Linux / Jetson newbie, so maybe I did something wrong, but I basicaly downloadd the wheel file and ran pip install tensorflow-1.7.0rc1-cp27-cp27mu-linux_aarch64.whl

Is that the right way to install it?

EDIT: I tried with ‘wheel install --force’, and I’m getting the same error as above (“zipfile.BadZipFile: File is not a zip file”). Any ideas?

It’s /usr/lib/aarch64-linux-gnu. But you need previous two PR.

Cool! peterlee0127
Thanks for your sharing.

Hi,

We have built TensorFlow 1.7 with TensorRT support.
Update the download link in comment #1.

Thanks.

Hi AastaLLL,

The link you have provided to whl in #1 supports TensorRT 3 or 4?

Also, I understand that this will not be useful for JetPack 3.1, correct?

thanks~

Hi, kanakiyab

The wheel is built for JetPack3.2, which is TensorRT 3.
For JetPack3.1, please check this GitHub for information:
https://github.com/JesperChristensen89/TensorFlow-Jetson-TX2

Thanks.

Since TensorRT is now integrated into Tensorflow, does that mean that it is possible to use the TensorRT Python API on ARM, e.g. Jetson TX2?

Thanks.

Hi AastaLLL
If TensorRT 4.0 and TensorFlow 1.7 is installed seperately on TegraX2, Is the integration b/w them taken care during installation process? Or Are there any wheel files that have Tensorflow 1.7 with TensorRT 4.0 integration?
Bottomline : I am trying to find a way to install TFlow 1.7 with TRT 4.0 integration on Jetson TX2.