TensorRT 8.0.0 local repo file installation broken on Ubuntu18.04

Description

After CUDA 11.3 is installed, following the local repo file installations instructions (at docs.nvidia com/deeplearning/tensorrt/install-guide/index.html) breaks with

$ sudo apt-get install python3-libnvinfer-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 python3-libnvinfer-dev : Depends: python3-libnvinfer (= 8.0.0-1+cuda11.3) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Environment

TensorRT Version: 8.0.0
GPU Type: GeForce GTX 1080
Nvidia Driver Version: 465.19.01
CUDA Version: 11.3
CUDNN Version: release 11.3, V11.3.58 Build cuda_11.3.r11.3/compiler.29745058_0
Operating System + Version: Ubuntu18.04
Python Version (if applicable): 3.8 or 3.6

Steps To Reproduce

sudo dpkg -i nv-tensorrt-repo-ubuntu1804-cuda11.3-trt8.0.0.3-ea-20210423_1-1_amd64.deb
sudo apt-key add /var/nv-tensorrt-repo-ubuntu1804-cuda11.3-trt8.0.0.3-ea-20210423/7fa2af80.pub
sudo apt-get update
sudo apt-get install tensorrt
sudo apt-get install python3-libnvinfer-dev

$ sudo apt-get install python3-libnvinfer-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 python3-libnvinfer-dev : Depends: python3-libnvinfer (= 8.0.0-1+cuda11.3) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Testing further

$ sudo apt-get install python3-libnvinfer
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 python3-libnvinfer : Depends: python3 (< 3.7) but 3.8.2-0ubuntu2 is to be installed

This reproduces for both python3.8 and python3.6

$ apt list python3
Listing... Done
python3/focal,focal,now 3.8.2-0ubuntu2 amd64 [installed]

Hi,
Please refer to the installation steps from the below link if in case you are missing on anything
https://docs.nvidia.com/deeplearning/tensorrt/install-guide/index.html
Also, we suggest you to use TRT NGC containers to avoid any system dependency related issues.
https://ngc.nvidia.com/catalog/containers/nvidia:tensorrt

Thanks!

Hi @wurmdario,

When we tried from our end, we could successfully install. This looks like some system dependency issue from your end. We request you to please make sure all prerequisites are installed. We recommend you to use TensorRT NGC container to avoid system dependencies.
Hope following old post may help you.

Thank you.