Tensorrt 8.0 installation

The following packages have unmet dependencies:
tensorrt : Depends: libnvinfer8 (= 8.0.0-1+cuda10.2) but 8.0.0-1+cuda11.3 is to be installed
Depends: libnvinfer-plugin8 (= 8.0.0-1+cuda10.2) but 8.0.0-1+cuda11.3 is to be installed
Depends: libnvparsers8 (= 8.0.0-1+cuda10.2) but 8.0.0-1+cuda11.3 is to be installed
Depends: libnvonnxparsers8 (= 8.0.0-1+cuda10.2) but 8.0.0-1+cuda11.3 is to be installed
Depends: libnvinfer-bin (= 8.0.0-1+cuda10.2) but it is not going to be installed
Depends: libnvinfer-dev (= 8.0.0-1+cuda10.2) but 8.0.0-1+cuda11.3 is to be installed
Depends: libnvinfer-plugin-dev (= 8.0.0-1+cuda10.2) but 8.0.0-1+cuda11.3 is to be installed
Depends: libnvparsers-dev (= 8.0.0-1+cuda10.2) but 8.0.0-1+cuda11.3 is to be installed
Depends: libnvonnxparsers-dev (= 8.0.0-1+cuda10.2) but 8.0.0-1+cuda11.3 is to be installed
Depends: libnvinfer-samples (= 8.0.0-1+cuda10.2) but it is not going to be installed
Depends: libnvinfer-doc (= 8.0.0-1+cuda10.2) but it is not going to be installed

Using, Ubuntu 18.04 and cuda 10.2

Hi,
Please refer to the installation steps from the below link if in case you are missing on anything
https://docs.nvidia.com/deeplearning/tensorrt/install-guide/index.html
Also, we suggest you to use TRT NGC containers to avoid any system dependency related issues.
https://ngc.nvidia.com/catalog/containers/nvidia:tensorrt

Thanks!

Hi @fjoseph,

Please make sure you downloaded correct deb package suitable for your CUDA version. or you can upgrade CUDA version to 11.3 and install 11.3 supported TensorRT package.
https://developer.nvidia.com/nvidia-tensorrt-8x-download

Thank you.

Thanks for the suggestion. I did download the 10.2 version which makes me wonder why I am getting the above error message.
I will try upgrading to 11.3.