unmet dependencies- tensorrt : Depends: libnvinfer5

Hi there,

I am trying to install,

tensorrt 5: nv-tensorrt-repo-ubuntu1604-cuda9.0-trt5.0.0.10-rc-20180906_1-1_amd64.deb
OS: Ubuntu 16.04
Language: python 2.7

I am following official installation guide and after the following command execution,

sudo apt-get install tensorrt

I am getting following error,

Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
tensorrt : Depends: libnvinfer5 (= 5.0.0-1+cuda9.0) but it is not going to be installed
Depends: libnvinfer-dev (= 5.0.0-1+cuda9.0) but it is not going to be installed
Depends: libnvinfer-samples (= 5.0.0-1+cuda9.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Hello,

this is unexpected. can you please upload the complete installation sequence and messages? starting with dpkg -i xxxx

thanks.

Hello,

i have the same problem:

apt-key add /var/nv-tensorrt-repo-cuda10.0-trt5.0.0.10-rc-20180906/7fa2af80.pub
dpkg -i nv-tensorrt-repo-ubuntu1804-cuda10.0-trt5.0.0.10-rc-20180906_1-1_amd64.deb
apt-get update
apt-get install tensorrt
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
tensorrt : Depends: libnvinfer5 (= 5.0.0-1+cuda10.0) but it is not going to be installed
Depends: libnvinfer-dev (= 5.0.0-1+cuda10.0) but it is not going to be installed
Depends: libnvinfer-samples (= 5.0.0-1+cuda10.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

OS: Ubuntu 18.04

Hello, do you have CUDA installed? Make sure you are download the right TensorRT version paired with the right version of CUDA you have installed.

vcc --version
nvcc: NVIDIA ® Cuda compiler driver
Copyright © 2005-2018 NVIDIA Corporation
Built on Sat_Aug_25_21:08:01_CDT_2018
Cuda compilation tools, release 10.0, V10.0.130

I am facing the same error

The following packages have unmet dependencies:
tensorrt : Depends: libnvinfer5 (= 5.0.2-1+cuda10.0) but it is not going to be installed
Depends: libnvinfer-dev (= 5.0.2-1+cuda10.0) but it is not going to be installed
Depends: libnvinfer-samples (= 5.0.2-1+cuda10.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Any suggestion

Same problem

Hello!

I have the same problem too.

I have the same problem
I’m installing TensorRT 4.0 from .deb file(nv-tensorrt-repo-ubuntu1604-cuda9.2-ga-trt4.0.1.6-20180612_1-1_amd64.deb)
cuda9.2 and cudnn 7.4 are already installed on Ubuntu 16.04
At first, I wanted to install TensorRT 5.0, but there’s no compatible version for cuda 9.2, so I use TensorRT 4.0 instead.
But got the same error.

b deep@deep:~/Downloads/cuda-9.2-toolchain »[/b] sudo apt-get install tensorrt
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
tensorrt : Depends: libnvinfer4 (>= 4.1.2) but it is not going to be installed
Depends: libnvinfer-dev (>= 4.1.2) but it is not going to be installed
Depends: libnvinfer-samples (>= 4.1.2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

b deep@deep:~/Downloads/cuda-9.2-toolchain » [/b]sudo apt-get install libnvinfer4
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libnvinfer4 : Depends: cuda-cublas-9-2 but it is not installable
E: Unable to correct problems, you have held broken packages.

@surgey

Use Tar file instead of deb file

For anyone who is still seeing this issue can you provide the output of “dpkg-query -W | grep cuda” and the filename of the local_repo deb file you are trying to install?

I solved this problem.
The reason is my cuda was installed by .run file.
Reinstall cuda 9.2 with deb pack and the tesorrt 4.0 goes well.

Thanks @gehaocool for providing an update.

I came across this issue when attempting to install tensorrt5 using the .deb installer. My problem was that i had the wrong version libcudnn7.

apt list | grep cudnn

libcudnn7/now 7.4.1.5-1+cuda9.0 amd64 [installed,local]
libcudnn7-dev/unknown 7.3.1.20-1+cuda9.0 amd64

I ran

sudo apt autoremove libcudnn7

to remove the newest version, downloaded the cudnn 7.3.1 runtime deb package, and installed that version.

libcudnn7/unknown,now 7.3.1.20-1+cuda9.0 amd64 [installed,automatic]
libcudnn7-dev/unknown,now 7.3.1.20-1+cuda9.0 amd64

After this I re-attempted the tensorrt install without any problems.

1 Like

Repros for me as of today; requested dpkg query output below the error message

johnu@ubunt-d1-16a:~$ sudo apt install tensorrt
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
tensorrt : Depends: libnvinfer5 (= 5.0.2-1+cuda10.0) but it is not going to be installed
Depends: libnvinfer-dev (= 5.0.2-1+cuda10.0) but it is not going to be installed
Depends: libnvinfer-samples (= 5.0.2-1+cuda10.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
johnu@ubunt-d1-16a:~ dpkg-query -W | grep cuda libcudnn7 7.4.2.24-1+cuda10.0 libcudnn7-dev 7.4.2.24-1+cuda10.0 libcudnn7-doc 7.4.2.24-1+cuda10.0 nv-tensorrt-repo-ubuntu1804-cuda10.0-trt5.0.2.6-ga-20181009 1-1 johnu@ubunt-d1-16a:~

and here is the same dpkg query executed for the tensorrt5 deb thingy:

ohnu@ubunt-d1-16a:~ dpkg-query -l | grep tensor ii nv-tensorrt-repo-ubuntu1804-cuda10.0-trt5.0.2.6-ga-20181009 1-1 amd64 nv-tensorrt repository configuration files johnu@ubunt-d1-16a:~ dpkg-query -W | grep tensor
nv-tensorrt-repo-ubuntu1804-cuda10.0-trt5.0.2.6-ga-20181009 1-1
johnu@ubunt-d1-16a:~$

I think you’re missing the CUDA 10.0 debian packages. You can install the following deb file to setup the CUDA network repo which will contain the CUDA 10.0 packages that you need.

http://developer.download.nvidia.com/compute/cuda/repos/ubuntu1804/x86_64/cuda-repo-ubuntu1804_10.0.130-1_amd64.deb

That was it. Thankyou!

On a QA note, shoudnt that instruction have been in the DeepStream_Release/README for DeepStreamSDK-Tesla-v3.0.tbz2?

Can an admin change this posting thread type so that i can mark it as solved?

Tnx!

johnu

Tensorrt is not working with libcudnn7/now 7.4.1.5-1+cuda9.0 amd64 [installed,local]. You need 7.3.1.

You need to install TensorRT 5.1.5 GA. thanks.

Thanks, this also solved my issue.