TENSORRT (libvinfer7 issue)

Description

I try to install Tensorrt but below error occurs.
duygu@duygu:~$ sudo apt-get install tensorrt=7.0.0.11-1+cuda10.0
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
tensorrt : Depends: libnvinfer7 (= 7.0.0-1+cuda10.0) but 7.2.3-1+cuda11.1 is to be installed
Depends: libnvinfer-plugin7 (= 7.0.0-1+cuda10.0) but 7.2.3-1+cuda11.1 is to be installed
Depends: libnvparsers7 (= 7.0.0-1+cuda10.0) but 7.2.3-1+cuda11.1 is to be installed
Depends: libnvonnxparsers7 (= 7.0.0-1+cuda10.0) but 7.2.3-1+cuda11.1 is to be installed
Depends: libnvinfer-bin (= 7.0.0-1+cuda10.0) but it is not going to be installed
Depends: libnvinfer-dev (= 7.0.0-1+cuda10.0) but 8.2.0-1+cuda11.4 is to be installed
Depends: libnvinfer-plugin-dev (= 7.0.0-1+cuda10.0) but 8.2.0-1+cuda11.4 is to be installed
Depends: libnvparsers-dev (= 7.0.0-1+cuda10.0) but 8.2.0-1+cuda11.4 is to be installed
Depends: libnvonnxparsers-dev (= 7.0.0-1+cuda10.0) but 8.2.0-1+cuda11.4 is to be installed
Depends: libnvinfer-samples (= 7.0.0-1+cuda10.0) but it is not going to be installed
Depends: libnvinfer-doc (= 7.0.0-1+cuda10.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Hi,
Please refer to the installation steps from the below link if in case you are missing on anything
https://docs.nvidia.com/deeplearning/tensorrt/install-guide/index.html
Also, we suggest you to use TRT NGC containers to avoid any system dependency related issues.
https://ngc.nvidia.com/catalog/containers/nvidia:tensorrt

Thanks!

Hello, I followed the first link you suggested. My nvcc --version gives CUDA 10 and I uploaded nv-tensorrt-repo-ubuntu1804-cuda10.0-trt7.0.0.11-ga-20191216_1-1_amd64.deb file.

Hi,

Please make sure you have dependencies installed correctly. If you face some issue, please uninstall and reinstall correctly using installation guide shared, also looks like you’re installing older version of TensorRT, we highly recommend you to please install latest TensorRT version.

Please check support matrix here Documentation Archives :: NVIDIA Deep Learning TensorRT Documentation

Also similar issue may help you Installing TensorRT on docker | Depends: libnvinfer7 (= 7.1.3-1+cuda10.2) but 7.2.0-1+cuda11.0 is to be installed · Issue #792 · NVIDIA/TensorRT · GitHub

Thank you.