Installing python3-libinfer-dev has been causing a few problems. Any help with installing it?

sudo apt-get install python3-libnvinfer-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 python3-libnvinfer-dev : Depends: python3-libnvinfer (>= 4.1.2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

So went on with installing python3-libnvinfer

sudo apt-get install python3-libnvinfer
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 python3-libnvinfer : Depends: python3 (< 3.6) but 3.6.7-1~18.04 is to be installed
E: Unable to correct problems, you have held broken packages.

At this point I tried aliasing python3 to be equal to python. The current default version of python is set to python3.5.7 now.

And TensorRT is not broken. Running dpkg gives me a success.

dpkg -s TensorRT | grep Status
Status: install ok installed

The current OS which I’m right now using is a spinoff of Ubuntu18.04 and TensorRT 4 with cuda 9.2