Tesla M10 with Windows Server 2019 VM - 3D options missing

Hi All,

Apologies if I’ve done something dumb.

We’ve just deployed our first GRID license with our Tesla M10 on our new Dell Poweredge servers.

It was all going well, I had the Solidworks user installing the Solidworks software and adjusting the 3D settings in the Nvidia Control Panel.

I shut down to allocate more RAM, restarted the VM and now the Control Panel doesn’t show any 3D settings. As in, the Control Panel no longer shows any option other than the License options.

I’ve connected to the GRID license server, allocated a vDWS license to the VM and I can see it’s been issued in the server.

I’ve tried the current version of the driver 442.06 and the previous version 441.66 and no change…

Any ideas?

Without this, it’s literally useless to me!


No idea what’s happened there.

First thought, uninstall / reinstall of NVIDIA driver.

You mention Server 2019. Is that RDSH or a single user VM? If RDSH, what’s your connection protocol?




Obviously I’ve tried uninstalling and reinstalling a dozen different ways and nothing.

RDSH, but we’re just connecting via RDP locally.

I’ll try a reinstall of the OS, I don’t want to waste anymore time on it. I’ve literally spent hours on it already trying to make it work.

We’re just experimenting at this point to see if it’s going to do what we want… Currently it’s not great…

Thanks for the reply!

Are you really going to run Solidworks with Tesla M10???