The Transform Window Now Resets After Every Manipulation

Ever since Kit 105, importing items from Blender is now vertical, instead of horizontal.

Then I change it as shown in this short video, and the transform window resets after every change.

Is this a bug?

Thanks if you can tell me why this resets? It used to stay after I changed something.

Hi there,
So first the transform issue. You are in “Offset Mode”. So when you go to rotate your object by 270 degrees, it resets backt to 0.0 once done. And all of those values stay at 0.0. To switch back to “Transform mode” click the little icon in the upper right above the Z value.

As for your Y/Z axis problem, it could be a couple of things. 1) check how you are exporting your data from your DCC. It will say either Y or Z. Second check your Stage Preferences.

Before this update I didn’t have to use the transform mode. I don’t know what the values mean when there are 4 of them in Transform mode?

There are not even labels next to these values, and if I were to guess compared to the mode I like to use, it would be position, rotate, scale, what is the 4th one?


Why aren’t there labels here? It was better to me the way it was before the update.

We have not taken anything away from the system. Only added it. If you do not wish to use the Offset system just stick to the regular Transform system.

Well you changed the offset mode, because before if I made a change, it stayed, it didn’t reset to 0.

Ah I see what you are saying. No, that would not be the correct workflow. Much like other DCC software, offset is always working from 0.0. Once you type in an offset it should move and re-zero out. The change you enter should then update in the regular transform mode.

So are you reporting this as a bug?

No this is not a bug. It is a correction. It now works correctly.

Well I liked it better working the way it was. I don’t know why there are 4 rows on transform view, and I can’t tell what value I set now because you erase it.

I hate to go back to the old version, but I guess I will have to.

I don’t see why you have 4 columns. It should be 3. X Y Z. Maybe reset your user preferences. I am not sure I understand why you need the offset to remain. That is not the way it is supposed to work. You have your offset and then you have your transform. As far as I know it has always worked that way.

Here is the screenshot of 4 rows.

I don’t know what this means?

I am not sure how you are getting this. Can you record a video of a totally fresh scene, add a cube and show me how you are getting this.

Here is a video of me doing the same thing

The issue seems to happen only with items from Blender.

I took a simple object from Blender, I did apply rotation and scale and then triangulate and apply that before exporting as a usdc.

The screen looks different with an object from Blender.

Ok this seems like this is a blender/composer issue, not just a Composer issue. It may be a bug, but not with composer as such. Are you using an OV connector from Blender or just saving as a native USD ? Try some other format. Like fbx. Do you use any other DCC software ? Also try actually opening the usd file, not dragging it in. You seem to just keep dragging it in, but that is nesting one usd into another. Just save your blender file as a usd and then use File > Open. Then go from there.

What I want to see if native vs blender. So make a cube, make a sphere, native in Composer. Show me that working fine. Then drag in some assets from the nvidia library. Then open a blender file with the File > Open. Let’s isolate the issue to a blender file. Have you recently updated blender ? If you want to install the old one and show me the difference that is fine.

Can you send me the USDc file please. Also why is it USDc ? Not just USD ?

I opened the file this time as you suggested, instead of dragging and dropping, and that did fix the item moving weirdly.

The Transform still appears with 4 rows.

I use IClone, and in the last 24 hours found a program called Unigen, which looks promising also. I will try that and some other formats.

Perhaps it is a Blender issue, but in the old version of Create this worked, so something changed.

I will try some other formats and see if I get similar results.

Thanks Corby

@DataJuggler It’s odd that you’re getting a single matrix for the transform. Just to confirm, are you using the Blender build from the Omniverse Launcher? If so, this version by default exports the transform as Scale, Rotate, Translate components, not a single matrix. Can you verify that in the USD export option General -> Xform Ops is set to the default Scale, Rotate, Translate?


Note that if you are using the mainline Blender release from the Blender Foundation (not from the Launcher), you won’t get this functionality and will always get the single matrix.

I think you solved it, because no, I was using the 3.6 full release, since Omniverse 3.6 Blender is in alpha.

I have both installed, and I imported the object I created earlier into the Omniverse version, and the transform node has 3 rows.

I guess the 3.6 official release version of Omniverse has some issues.

Thanks, I will stick with the Omniverse version. I don’t know if the Omniverse Blender team has any ties to the official Blender team, but they are quite different.


I’m glad it’s working! Indeed, we are working directly with the Blender Foundation to port the USD features in the Omniverse build to the official main branch.

1 Like