thread_load.cuh(292) error

Hello.

I’m just trying to do “Sync projects to create remote builds on targets” on this site.

https://devblogs.nvidia.com/parallelforall/remote-application-development-nvidia-nsight-eclipse-edition/

My remote device is JetsonTX1 jetpack2.3.1 is installed.

Building and executing sample app “particle” for local PC was end in success.

But it was failed for JetsonTX1.

The nsight’s message is as below.
###########################################################################
6:44:27 **** Build of configuration Release for project particles ****
make all -C /home/ubuntu/cuda-workspace/particles/Release
make: Entering directory ‘/home/ubuntu/cuda-workspace/particles/Release’
Building file: …/src/particleSystem.cpp
Invoking: NVCC Compiler
/usr/local/cuda-8.0/bin/nvcc -I"/usr/local/cuda-8.0/samples/5_Simulations" -I"/usr/local/cuda-8.0/samples/common/inc" -I"/home/HOSTPC_username/cuda-workspace/particles" -I/usr/local/cuda-8.0/include -O3 -ccbin arm-linux-gnueabihf-g++ -gencode arch=compute_20,code=sm_20 -gencode arch=compute_50,code=sm_50 -m32 -odir “src” -M -o “src/particleSystem.d” “…/src/particleSystem.cpp”
nvcc warning : The ‘compute_20’, ‘sm_20’, and ‘sm_21’ architectures are deprecated, and may be removed in a future release (Use -Wno-deprecated-gpu-targets to suppress warning).
/usr/local/cuda-8.0/bin/nvcc -I"/usr/local/cuda-8.0/samples/5_Simulations" -I"/usr/local/cuda-8.0/samples/common/inc" -I"/home/HOSTPC_username/cuda-workspace/particles" -I/usr/local/cuda-8.0/include -O3 --compile -m32 -ccbin arm-linux-gnueabihf-g++ -x c++ -o “src/particleSystem.o” “…/src/particleSystem.cpp”
nvcc warning : The ‘compute_20’, ‘sm_20’, and ‘sm_21’ architectures are deprecated, and may be removed in a future release (Use -Wno-deprecated-gpu-targets to suppress warning).
Finished building: …/src/particleSystem.cpp

Building file: …/src/particleSystem_cuda.cu
Invoking: NVCC Compiler
/usr/local/cuda-8.0/bin/nvcc -I"/usr/local/cuda-8.0/samples/5_Simulations" -I"/usr/local/cuda-8.0/samples/common/inc" -I"/home/HOSTPC_username/cuda-workspace/particles" -I/usr/local/cuda-8.0/include -O3 -ccbin arm-linux-gnueabihf-g++ -gencode arch=compute_20,code=sm_20 -gencode arch=compute_50,code=sm_50 -m32 -odir “src” -M -o “src/particleSystem_cuda.d” “…/src/particleSystem_cuda.cu”
nvcc warning : The ‘compute_20’, ‘sm_20’, and ‘sm_21’ architectures are deprecated, and may be removed in a future release (Use -Wno-deprecated-gpu-targets to suppress warning).
/usr/local/cuda-8.0/bin/nvcc -I"/usr/local/cuda-8.0/samples/5_Simulations" -I"/usr/local/cuda-8.0/samples/common/inc" -I"/home/HOSTPC_username/cuda-workspace/particles" -I/usr/local/cuda-8.0/include -O3 --compile --relocatable-device-code=false -gencode arch=compute_20,code=compute_20 -gencode arch=compute_50,code=compute_50 -gencode arch=compute_20,code=sm_20 -gencode arch=compute_50,code=sm_50 -m32 -ccbin arm-linux-gnueabihf-g++ -x cu -o “src/particleSystem_cuda.o” “…/src/particleSystem_cuda.cu”
nvcc warning : The ‘compute_20’, ‘sm_20’, and ‘sm_21’ architectures are deprecated, and may be removed in a future release (Use -Wno-deprecated-gpu-targets to suppress warning).
/usr/local/cuda-8.0/include/thrust/system/cuda/detail/cub/block/specializations/…/…/block/…/block/specializations/…/…/warp/specializations/…/…/thread/thread_load.cuh(292): error: asm operand type size(8) does not match type/size implied by constraint ‘r’

1 error detected in the compilation of “/tmp/tmpxft_00000fe6_00000000-19_particleSystem_cuda.compute_50.cpp3.i”.
src/subdir.mk:42: recipe for target ‘src/particleSystem_cuda.o’ failed
make: Leaving directory ‘/home/ubuntu/cuda-workspace/particles/Release’
make: *** [src/particleSystem_cuda.o] Error 1

Shell Completed (exit code = 2)
#############################################################################

This message suggests “thread_load.cuh(292)” causes error.
The line 292 says,
#if CUB_PTX_ARCH >= 350
CUB_LOAD_ALL(LOAD_LDG,global.nc).

Could anyone tell me how to cope with this issue?

Thank you.

Hello.

I was able to solve this issue by myself.

In Setting mode on Project’s property Tab, I changed GeneratePTX code value to 2.0.

Thanks.