How to use the Jetpack TX1 and Nvidia Nsight Eclipes ?

I have got the Jetson TX1 Development Kit.Following the nvidia instruction ,I have installed the Jetson Pack 2.3 in my computer with linux and flash the Jetson TX1 with ubuntu.I build a CUDA example ,after builing ,there are alway errors.The next step is that I want to program and launch to Jetson TX1,but I don’t how ?

If you install via JetPack there should be some parts of setup done. Manual setup without JetPack can be someone more difficult, so assuming you use JetPack here’s some starting information:
https://devblogs.nvidia.com/parallelforall/remote-application-development-nvidia-nsight-eclipse-edition/
https://developer.nvidia.com/nsight-eclipse-edition
http://www.nvidia.com/object/nsight.html

Thank you for you answer. But there are error too.
I can list what I have and what I have done now.

  1. I have host computer running Ubuntu 14.04; The Jetson TX1 Development Kit.
  2. I got the JetPack for L4T 2.3 in
    "https://developer.nvidia.com/embedded/downloads?#?dn=jetpack-for-l4t-2-3
    then I install the JetPack and flash Jetson TX1 successfully.
  3. Running Nvidia nsight in my host computer, File-> new-> CUDA C/C++ Project-> type project name import CUDA example-> choose example-> Basic setting-> Target setting add remote target-> next ,finish.
  4. In the nsight windows ,Project-> Build configuration-> set active->…If I choose “local debug” and then build the project,there is no error. But if I choose “Jetson TX1(remote target name) Debug” and the build, there is an error.

At first ,the error shows that “arm-linux-gnueabihf-g++: no such file or directory”. So I install arm-linux-gnueabihf-g++ in my host computer and Jetson TX1, the error is gone. But another error shows up, see the below:
////////////////////////////////////////////////////////////////////////////////
20:49:51 **** Incremental Build of configuration Debug for project dd ****
make all -C /home/ubuntu/dd/Debug
make: Entering directory ‘/home/ubuntu/dd/Debug’
Building file: …/src/vectorAdd.cu
Invoking: NVCC Compiler
/usr/local/cuda-8.0/bin/nvcc -I"/usr/local/cuda-8.0/samples/0_Simple" -I"/usr/local/cuda-8.0/samples/common/inc" -I"/home/hello-hzb/my_gpu_work/dd" -G -g -O0 -ccbin arm-linux-gnueabihf-g++ -gencode arch=compute_50,code=sm_50 -m32 -odir “src” -M -o “src/vectorAdd.d” “…/src/vectorAdd.cu”
cc1plus: fatal error: cuda_runtime.h: No such file or directory
compilation terminated.
src/subdir.mk:18: recipe for target ‘src/vectorAdd.o’ failed
make: Leaving directory ‘/home/ubuntu/dd/Debug’
make: *** [src/vectorAdd.o] Error 1

Shell Completed (exit code = 2)

20:49:52 Build Finished (took 932ms)
/////////////////////////////////////////////////////////////////////////////////

I am new to Jetson TX1. I want to run an example in Jetson TX1. And then I can program my code and run in Jetson TX1. The addresses you gave me are not fit me well. Can you teach me how to use the Nvidia to develop the Jetson TX1?

I use a Fedora host, but JetPack requires an Ubuntu host, so I don’t have the ability to debug JetPack issues when the install being debugged is for host…there is environment setup involved in configuring nsight, and JetPack provides that setup when installing to Ubuntu.

One detail which catches my attention here is this missing file:

arm-linux-gnueabihf-g++

The named compiler is for 32-bit armhf, not 64-bit aarch64. CUDA 8 requires aarch64, and in theory your JetPack version should have installed R24.2 (or at least R24.1)…those releases do not have 32-bit user space. Somewhere in all of that install procedure 32-bit and 64-bit has been intermixed. I have no idea where this would have happened, but I suspect this is why there is a failure. Maybe it is just a setting in nsight, but I don’t know.