Install CUDA on a latestly flashed JTX1

After an installation with JetPack-L4T-2.3.1-linux-x64.run, CUDA is missing except the following
/usr/lib/aarch64-linux-gnu/tegra/libcuda.so.1.1
/usr/lib/aarch64-linux-gnu/tegra/libcuda.so
/usr/lib/aarch64-linux-gnu/tegra/libcuda.so.1
/usr/lib/aarch64-linux-gnu/libcuda.so

ubuntu@tegra-ubuntu:~$ nvidia-detector
none
none

ubuntu@tegra-ubuntu:~ update-pciids update-pciids: /usr/share/misc/pci.ids.new is read-only ubuntu@tegra-ubuntu:~ lspci | grep -i nvidia
ubuntu@tegra-ubuntu:~ ubuntu@tegra-ubuntu:~

ubuntu@tegra-ubuntu:~$ uname -m && cat /etc/*release
aarch64
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=16.04
DISTRIB_CODENAME=xenial
DISTRIB_DESCRIPTION=“Ubuntu 16.04 LTS”

R24 (release), REVISION: 2.1, GCID: 8028265, BOARD: t210ref, EABI: aarch64, DATE: Thu Nov 10 03:51:59 UTC 2016

ubuntu@tegra-ubuntu:~$ gcc --version
gcc (Ubuntu/Linaro 5.3.1-14ubuntu2.1) 5.3.1 20160413
Copyright © 2015 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

ubuntu@tegra-ubuntu:~$ uname -r
3.10.96-tegra

As per the 4.3.1.1 section on http://developer.download.nvidia.com/compute/cuda/8.0/secure/prod/docs/sidebar/CUDA_Quick_Start_Guide.pdf?autho=1482994795_0ac284e35bd8e16826302ea4eca8c414&file=CUDA_Quick_Start_Guide.pdf, a worklist happens as below:

scp cuda-repo-l4t-8-0-local_8.0.34-1_arm64.deb JTX1

ubuntu@tegra-ubuntu:~ sudo dpkg --install cuda-repo-l4t-8-0_local_8.0.34-1_arm64.deb ubuntu@tegra-ubuntu:~ sudo apt-get update
ubuntu@tegra-ubuntu:~ sudo apt-get install cuda-toolkit-8-0 ubuntu@tegra-ubuntu:~ sudo reboot
ubuntu@tegra-ubuntu:~ export PATH=/usr/local/cuda-8.0/bin{PATH:+:{PATH}} ubuntu@tegra-ubuntu:~ export LD_LIBRARY_PATH=/usr/local/cuda-8.0/lib64${LD_LIBRARY_PATH:+:{LD_LIBRARY_PATH}} ubuntu@tegra-ubuntu:~ cuda-install-samples-8.0.sh ~
ubuntu@tegra-ubuntu:~ cd ~/NVIDIA_CUDA-8.0_Samples/0_Simple/vectorAdd ubuntu@tegra-ubuntu:~ make
ubuntu@tegra-ubuntu:~$ ./vectorAdd

ubuntu@tegra-ubuntu:~$ nvcc -V
nvcc: NVIDIA ® Cuda compiler driver
Copyright © 2005-2016 NVIDIA Corporation
Built on Fri_Jul_15_14:52:12_CDT_2016
Cuda compilation tools, release 8.0, V8.0.33

Was JetPack able to connect to your Jetson over ethernet (SSH) after flashing L4T?

You could also try running the JetPack post-install steps again, including CUDA. This will configure the packages without re-flashing first.

Hi dusty_nv,

While my eth cable was connecting to JTX1, I retried running JetPack-L4T-2.3.1-linux-x64.run, ticked CUDA without OpenCV4Tegra on subsequencial GUI on host side, pressed/released PWR/REC/RST buttons by console prompts, saw no change on console, so the workaround mentioned above was found out. Any comment is welcomed.

Baring selecting the correct networking connection option in JetPack (i.e. wired through router vs. wired directly from extra ethernet interface), installing the packages manually as you’ve done should be just fine too. If you require additional packages to install manually, such as TensorRT or Tegra Multimedia API, those can be found under the ‘jetpack_download’ directory that JetPack created.

Also, you may want to append the export PATH and LD_LIBRARY_CONFIG paths to your user’s ~/.bashrc, so these persist after reboot or after re-opening terminal:

export PATH=/usr/local/cuda-8.0/bin:$PATH
export LD_LIBRARY_PATH=/usr/local/cuda-8.0/lib64:$LD_LIBRARY_PATH