Install CUDA on L4T 24.1?

I unboxed a new TX1 dev kit, and flashed the 24.1 image/filesystem onto it. Because presumably I want all those driver updates, right?

Surprise surprise, there’s no CUDA.

I don’t see a download link for CUDA (or any of the other tools) that’s compatible with L4T 24.1. Everything is 23.1/ 23.2

I tried installing the cuda-repo-l4t-23.1 .deb but it’s the wrong architecture (hardfp instead of aarch64).

I also tried installing JetPack 2.1 but that failed in a dozen different ways.

Was I mistaken to flash 24.1? Is it not ready for prime time? Should I let JetPack 2.1 flash my device? Then how do I install the new drivers and 64-bit userspace?

Thanks,
Sean

R24.1 just came out. Previously it was ARMv8 32-bit user space, ARMv8a 64-bit kernel space…now it is all ARMv8a 64-bit. It’s possible some parts of the system did not yet get full 64-bit upgrades. I don’t know if R24.1 is considered beta or not, but usually the L4T releases using odd major-version are full release, and even versions are somewhere between, e.g., R19.x, R21.x, R23.x are full release…R24.x might be beta, not sure. Since it just now came out there’ll probably be a lot more questions and answers over the next few days.

i was reading this page,


and it states that the current 24.1 release is an early access beta and that an official 24.1 will be coming at some point in the future. has any time frame for the release of the official been talked about yet? also, i’m curious if in the official release there will be a group of software packages included like last release? like an update to jetpack package.

If you click on the link “TX1 Linux For Tegra R23.2 Supported Features” you’ll get to “Linux For Tegra R24.1” without any points to be BETA.

So, my impression is that L4T R24.1 is released.

ok. had not seen that,now i agree with that, there are different dates on the beta , feb 16 2016 vs current release may 17 2016. so they do seem to be different packages. thanks.

Thought I saw a listing in the downloads for arm64 cuda but I was mistaken. Took the cuda-repo.deb apart and noticed the libs are armhf hard float which is deprecated in this release. I was thinking that since this release is dual 32 64 userspace if you could actually get the libs installed they might work ok. If you want to try the repo is in cuda-l4t after a jetpack install. This command will take it all apart dpkg-deb -x hello_2.4-1_i386.deb hello substitute cuda-repo filename of course. The debs for the install are in the var/cuda-repo-7-0-local lib created by taking the deb apart. Should be able to run dpkg and install all these files on top of 24.1. Might try it later today. I want to go to this version as well I run into the not wanting to boot when hot issue all the time using the Zed for long periods. Really heats up the SOC.

Dan

Looked into the .deb file that the jetpack installs in /home/ubuntu/cuda-l4t. If you take that apart there is a Packages.gz file inside
If you unzip that file and look inside for each package there is an Architecture keyword. If memory serves you can change that to arm64 to get them to install on the filesystem. Armhf still works with 24.1 so they should work if you can get them to install. The cuda-repo-l4t-r23.1-7-0-local_7.0-73_armhf.deb is also in the jetpack_download directory where you installed the jetpack files if you don’t want to flash to grab the file. Looks like that is the file that contains all the cuda stuff and dpkg installs it. Another way that might work is to hook up a sata drive. Install with the 23.x version then copy the cuda directories to the sata drive. Install 24.1 then remount /usr/local. Not sure if there are any files on the system other than those in /usr/local/cuda though. Looks like Nv keeps it all in /usr/local but I don’t know for sure. My system is set up to have /home /opt and /usr/local on a sata drive so I know it will work that way but the root was installed with Jetpack.

Dan

Any progress on this? Not sure what point there is of moving to 24.1 without cuda. What about opencv4tegra?

See:
https://devtalk.nvidia.com/default/topic/920739/jetson-tx1/l4t-r23-2-for-jetson-tx1-released/post/4893600/#4893600

Are we getting an updated CUDA for JTX1?

Yes, it is now available. Please see here — https://devtalk.nvidia.com/default/topic/941913/jetson-tx1/jetpack-2-2-l4t-r24-1-64-bit-and-32-bit-cuda-released/