Error: CUDA cannot be installed on device

While installing Jetpack 2.0 on a Jetson TX1 I encountered the following error.

Error: CUDA cannot be installed on device. Please use apt-get command in a terminal to make sure following packages are installed correctly on device before continuing:
cuda-toolkit-7-0 libgomp1 libfreeimage-dev libopenmpi-dev openmpi-bin
After these packages are installed on device, press Enter key to continue

I have attempted to install these packages manually, however I have had no success.

The installer does not continue if I press enter.

I have tried restarting the process from beginning however I encounter the same problem.

Can anyone advise?

Have you tried redownloading the entire jetpack and reinstalling?

I have not, let me attempt that.

I have attempted to do another install, and I have redownloaded the JetPAck files. Unfortunately I still get the same error…

I have copied additional information in case it would be useful.

GET:36 http://ports.ubuntu.com trusty/universe Sources [6,399 kB]
89% [36 Sources 5,270 kB/6,399 kB 82%]Write failed: Broken pipe
ssh: connect to host **...25 port 22: Connection refused

Error: CUDA cannot be installed on device. Please use apt-get command in a terminal to make sure following packages are installed correctly on device before continuing:
cuda-toolkit-7-0 libgomp1 libfreeimage-dev libopenmpi-dev openmpi-bin
After these packages are installed on device, press Enter key to continue

I cannot locate the correct files I need to manually install them, If perhaps if someone from NVIDIA can shed some light it would be appreciated…

Otherwise, I’m lost here.

That sure looks like install failure is due to lost networking…web server and/or ssh. At some point it got to a requirement for ports.ubuntu.com, and choked…then ssh choked. I lack an Ubuntu host, so I can’t debug that. However, can you ping your Jetson from any other machine?

Like linuxdev said, looks like a networking issue. Does your network or router have a firewall?

Thank you for all of the input, Perhaps it is the firewall blocking the device, I am looking into that.

Alright, I had another device on the network with the same ip address, this was causing the error. Once I resolved the conflict everything installed correctly.

I have the same issue on a Jetson TX1. I haven’t actually checked for ip address conflict. But the cuda-l4t folder created inside the ~/home has a .deb file. I tried installing it with Ubuntu Software Center. But it gave an error saying:

Wrong architecture 'arm64'

. Is it possible to resolve it even if I have no issues in my network?

Is this R23.2? R24.1?

This is 23.2

I have manually installed CUDA without JetPack, which works. I am thinking about two possibilities for why it won’t work. First, see if the nVidia-specific files are correct:

sha1sum -c /etc/nv_tegra_release

Second, the .deb file used for installing CUDA is actually a repository file, and then the apt package system does the actual CUDA install. If you got the wrong repo .deb file, then this would account for the problem. I can’t use JetPack because my host is Fedora, but JetPack does offer some options for what to install where, I’m wondering if there was any kind of selection where somehow it might have thought you intended to install CUDA for something else which wasn’t intended for a Jetson? E.G., JetPack is able to install CUDA to the x86_64 host, and JetPack runs on an x86_64 host, but options give JetPack access to multiple CUDA repo .deb files other than x86_64. The repo .deb file which goes with R23.2 is this one:

cuda-repo-l4t-r23.1-7-0-local_7.0-73_armhf.deb

…this is because R23.2 has mixed 32-bit and 64-bit support. If you were installing to R24.1, then this is the .deb file used:

cuda-repo-l4t-7-0-local_7.0-76_arm64.deb

Double check to see if there are options for 32-bit armhf CUDA 7.0 configured, or if maybe it got the 64-bit arm64 CUDA 7.0 instead.

I got it done. I copied

cuda-repo-l4t-r23.1-7-0-local_7.0-73_armhf.deb

to the same folder as that of

cuda-l4t.sh

and ran the following command

./cuda-l4t.sh cuda-repo-l4t-r23.1-7-0-local_7.0-73_armhf.deb 7.0 7-0

Thanks for the help.

Ref: http://www.slothparadise.com/how-to-install-cuda-on-nvidia-jetson-tx1/

Maybe you have changed the default ssh port? The installer send some ssh/scp commands to copy the sw…