CUDA not getting installed when using Jetpack 3.2

I flashed my Jetson TX1 with Jetpack 3.2. I went through all the steps just as specified in: https://docs.nvidia.com/jetpack-l4t/index.html#developertools/mobile/jetpack/l4t/3.2/install.htm
When trying to run the CUDA samples I do not find the files. I do not find the directory /home/ubuntu/NVIDIA_CUDA. I try then the command nvcc -v and I get: command not found. Isn’t CUDA supposed to get installed automatically when flashing the Jetson TX1 with Jetpack ? Thanks

Duplicate of:
https://devtalk.nvidia.com/default/topic/1032466/cuda-not-getting-installed-when-using-jetpack-3-2/?offset=1#5252650
(but this is the better place for the question)

Do note that files typically are installed under “/usr/local/cuda-”. The executable files and samples won’t be in your default search path, so you might need to just cd to the right place (e.g., “cd /usr/local/cuda-9.0/”), and then there will be a “samples/” subdirectory and “tools/” and “bin/”. Check if what you are looking for might be there in that alternate location.

the problem is I do not have such directory: /usr/local/cuda … basically there is no cuda …

Those files are normally installed via JetPack when CUDA is checked as an option (wired ethernet will do the file copies after a flash is completed and reboot has occurred).

Do note that you can run JetPack at any later time and uncheck other operations and just have it install CUDA on the Jetson via wired ethernet. You might have to manually tell it what the IP address is. Also, be sure your host has package “ssh-askpass”…sometimes (not always) ssh may prompt for a password via a pop-up (which this package makes possible). Otherwise be sure to monitor the console of JetPack so you can see any requests for addresses or passwords.

Both my host computer and my Jetson are wired to a router using ethernet @linuxdev. In the components manager,I checked “full” to install everything including CUDA. After reboot I still cannot see it. It has not been installed

If JetPack was unable to find the IP address after flash this would happen. If you run JetPack at a later date the mechanism for finding the address is not in place…try again and make sure you manually enter the address (uncheck everything except CUDA just to try this). Be sure you have the ssh-askpass package on the host.

Hi,

It’s recommended to try the suggestions of linuxdev first?
If the error goes on, please share the log located in [JetPack_Folder]/_installer/logs with us.

Thanks.

I entered manually the IP and CUDA files are now on my computer however there are errors. Here is the log:
Configuration file ‘/etc/apt/sources.list.d/cuda-9-0-local.list’, does not exist on system.
Installing new config file as you requested.
W: GPG error: file:/var/cuda-repo-9-0-local Release: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY F60F4B3D7FA2AF80
W: The repository ‘file:/var/cuda-repo-9-0-local Release’ is not signed.
N: Data from such a repository can’t be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: Failed to fetch http://poarch=amd64rts.ubuntu.com/ubuntu-ports/dists/xenial-security/InRelease Could not resolve ‘poarch=amd64rts.ubuntu.com
E: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/xenial/main/binary-amd64/Packages 404 Not Found [IP: 2001:67c:1360:8001::22 80]
E: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/xenial-updates/main/binary-amd64/Packages 404 Not Found [IP: 2001:67c:1360:8001::22 80]
E: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/xenial-security/main/binary-amd64/Packages 404 Not Found [IP: 2001:67c:1360:8001::22 80]
E: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/xenial-backports/universe/binary-amd64/Packages 404 Not Found [IP: 2001:67c:1360:8001::22 80]
E: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/xenial-proposed/universe/binary-amd64/Packages 404 Not Found [IP: 2001:67c:1360:8001::22 80]
W: Some index files failed to download. They have been ignored, or old ones used instead.
E: Unable to locate package libfreeimage-dev
E: Unable to locate package libopenmpi-dev
E: Unable to locate package openmpi-bin

For first error, you may try https://devtalk.nvidia.com/default/topic/1030831/jetpack-3-2-mdash-l4t-r28-2-production-release-for-jetson-tx1-tx2/?offset=14#5245450.

It also seems you’ve edited your /etc/apt/sources.list and inserted arch info in the middle of the url:

http://po<b><s>arch=amd64</s></b>rts.ubuntu.com/ubuntu-ports/dists/xenial-security/InRelease

.
You may edit again and correct it.

[EDIT: It’s unclear to me… Are you facing this on Jetson or host ?]

I’m not sure of the significance, but it does seem related to edited sources.list. Note that this address is in your error:
http://ports.ubuntu.com/ubuntu-ports/dists/xenial-security/main/binary-amd64/Packages
…but that server only has up to this directory:
http://ports.ubuntu.com/ubuntu-ports/dists/xenial-security/main/
…the suffix “binary-amd64” is for a desktop PC, not for a Jetson. This dpkg respository is not meant for a desktop, and there is no reason a Jetson should be looking for amd64.

If JetPack is looking for amd64 to put on the Jetson, then something is quite wrong. If your desktop is searching for amd64 on an ARM repo, then there may be other issues…it is a bit confusing. Something somewhere in architectures is not quite right.

Thank you very much !.I got it working by combining the last 2 answers.