Some errors of installing Jetpack 3.3 to Jetson TX2

After I connected the TX2 with my host and entered the recovery mode of TX2,some errors appeared in my host:

Error:CUDA cannot be installed on device.This may be caused by other apt-get command running on device when installing CUDA.Please use apt-get command in a terminal to make sure following packages are installed correctly on device before continuing:
cuda-toolkit-9-0 libgompl libfreeimage-dev libopenmpi-dev openmpi-bin
After these packages are installed on device,press Enter key to continue

Hi 1210733943,

There have been some issues I believe with keys, and purging keys helps, but also can it be confirmed that all packages being installed via JetPack are from the same version of JetPack which was used to flash the Jetson? Mixed versions won’t work.

Assuming the JetPack version isn’t being mixed, try this:
https://devtalk.nvidia.com/default/topic/1032344/jetson-tx2/install-failure-unmet-dependencies/post/5277822/#5277822