Error Installing Cuda with Jetpack 3.3

I am using Jetpack 3.3 to install Cuda where i am running into the issue shown in the screenshot below

Hi,

Could you reboot your device and run the JetPack again?
// Just install the package after rebooting

Thanks.

I rebooted and run the jetpack again. I got the same error.Attaching screenshot for reference

I am not able guess whats going wrong. Can someone give some idea for me to resolve this issue?

Here is a similar thread which might help:
https://devtalk.nvidia.com/default/topic/1036338/jetson-tx1/unable-to-complete-post-installation-of-jetpack-3-2-on-tx1-cuda-9-0-installation-fails/

This particular note from that thread solved the issue in one case:
https://devtalk.nvidia.com/default/topic/1036338/jetson-tx1/unable-to-complete-post-installation-of-jetpack-3-2-on-tx1-cuda-9-0-installation-fails/post/5264984/#5264984

Hi,

This is a known issue which is caused by some libraries from the repository cannot be installed.
Could you try if this workaround also works for you?
https://devtalk.nvidia.com/default/topic/1032344/jetson-tx2/install-failure-unmet-dependencies/post/5277822/#5277822

Thanks.

My host locale was in en_in , i moved to en_us but still i could not get pass this error

->
apt-get purge cuda-license-
apt-get purge cuda-repo-*
dpkg --remove-architecture arm64
apt-get update
apt-get install g+±aarch64-linux-gnu
reinstall CUDA with JetPack

The above steps needs to be executed on the JetsonTx2 or in the host?

if i execute the below in my jetson tx2 i get this error

nvidia@tegra-ubuntu:~$ sudo dpkg --remove-architecture arm64
dpkg: warning: cannot remove non-foreign architecture ‘arm64’

I executed the above commands in HOST (ubuntu-16.04) and i could not go pass the “CUDA Cannot be installed on the device”.

My Host in ubuntu 16.04 has the following in /etc/apt/sources.list, does it need any modification :

deb http://archive.ubuntu.com/ubuntu xenial main restricted
deb http://archive.ubuntu.com/ubuntu xenial-updates main restricted
deb http://archive.ubuntu.com/ubuntu xenial universe
deb http://archive.ubuntu.com/ubuntu xenial-updates universe
deb http://archive.ubuntu.com/ubuntu xenial multiverse
deb http://archive.ubuntu.com/ubuntu xenial-updates multiverse
deb http://archive.canonical.com/ubuntu xenial partner
deb http://archive.ubuntu.com/ubuntu xenial-security main restricted
deb http://archive.ubuntu.com/ubuntu xenial-security universe
deb http://archive.ubuntu.com/ubuntu xenial-security multiverse
deb http://security.ubuntu.com/ubuntu trusty-security main
deb [arch=amd64] https://download.docker.com/linux/ubuntu xenial stable

My jetson has the following in /etc/apt/sources.list:

deb http://ports.ubuntu.com/ubuntu-ports/ xenial main restricted universe multiverse
deb-src http://ports.ubuntu.com/ubuntu-ports/ xenial main restricted universe multiverse
deb http://ports.ubuntu.com/ubuntu-ports/ xenial-updates main restricted universe multiverse
deb-src http://ports.ubuntu.com/ubuntu-ports/ xenial-updates main restricted universe multiverse
deb http://ports.ubuntu.com/ubuntu-ports/ xenial-security main restricted universe multiverse
deb-src http://ports.ubuntu.com/ubuntu-ports/ xenial-security main restricted universe multiverse

Hi,

The command is executed on the device.

Have you executed the following steps:

apt-get update
apt-get install g++-aarch64-linux-gnu

And reinstall CUDA with JetPack?

Thanks.

When i tried on the JetsonTx2, am getting this error
nvidia@tegra-ubuntu:~$ sudo apt-get install g+±aarch64-linux-gnu
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package g+±aarch64-linux-gnu
E: Couldn’t find any package by regex ‘g+±aarch64-linux-gnu’

I tried specifying the version https://packages.ubuntu.com/en/xenial/amd64/g+±4.9-aarch64-linux-gnu/download as well like this, still the same error ->

sudo apt-get install g+±4.9-aarch64-linux-gnuReading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package g+±4.9-aarch64-linux-gnu
E: Couldn’t find any package by glob ‘g+±4.9-aarch64-linux-gnu’
E: Couldn’t find any package by regex ‘g+±4.9-aarch64-linux-gnu’

Got this thread -> https://devtalk.nvidia.com/default/topic/1035797/problems-installing-jetpack-on-jetson-tx2/

will follow some suggestion from it to see if it helps solve my case

I reimaged a new Host with 16.04 (without CUDA proc) and tried doing the CUDA setup, still i could not go pass the same error. Can someone throw me some suggestion on how can i complete my CUDA Setup in Jetson tx2?
Attaching the log screen shot when trying to setup CUDA on host using new ubuntu host, this is same error as the message in the first one.
newhost.png

I reflashed my Jetson again and this time i selected “setup DHCP server in host” option and i found my cuda toolkit installation is successful :)
jetsonsucess.png

Hi,

Thanks for your update.

We have passed the issue in comment #14 to our internal team.
Will update information with you if any progress.

Thanks.

Hi,

We want to check #14 issue in detail.
Since we don’t meet the same error on our environment, could you help us collect the error log?

1. Reflash the device.
2. Apply the workaround shared in #6.

If CUDA package still cannot be installed, please share the log information located at <JetPack_Dir>/_installer/logs with us.

Thanks.

I will retry the above and get you the logs give me some time