Issue with TX2 debugging with nsight in "sync projects" mode

I’m just starting in the Jetson development process. I have a TX2, and have loaded it up with JetPack using an x86 Ubuntu host. Now if I want to run and profile cuda code on the TX2, it sounds like it’s easier to avoid cross compilation and go with the sync projects approach.

So i run up my nsight-eclipse on he host, and attempt the directions in https://devblogs.nvidia.com/remote-application-development-nvidia-nsight-eclipse-edition/.
I set up git on both host and target, I add a new target system (the TX2) without difficulty, and the comms look clean. I set up a host project using the cuda sample ‘simulations/particle’. I then go to run it as remote c++ app, which I was (maybe naively) expecting to

  1. copy over the relevant c++/.cu files to the tx2
  2. compile on the tx2
  3. run/debug on the tx2.

Sadly no:

(in dialog box)
Launching particle on Jetson…
launching Build Before launch…

14:13:52 **** Build of configuration Debug for project particle ****
make all
Building file: …/src/particleSystem.cpp
Invoking: NVCC Compiler
/usr/local/cuda-9.0/bin/nvcc -I"/usr/local/cuda-9.0/samples/5_Simulations" -I"/usr/local/cuda-9.0/samples/common/inc" -I"/home/pcox/cuda-workspace/particle" -G -g -O0 -gencode arch=compute_30,code=sm_30 -odir “src” -M -o “src/particleSystem.d” “…/src/particleSystem.cpp”
/usr/local/cuda-9.0/bin/nvcc -I"/usr/local/cuda-9.0/samples/5_Simulations" -I"/usr/local/cuda-9.0/samples/common/inc" -I"/home/pcox/cuda-workspace/particle" -G -g -O0 --compile -x c++ -o “src/particleSystem.o” “…/src/particleSystem.cpp”
Finished building: …/src/particleSystem.cpp

Building file: …/src/particleSystem_cuda.cu
Invoking: NVCC Compiler
/usr/local/cuda-9.0/bin/nvcc -I"/usr/local/cuda-9.0/samples/5_Simulations" -I"/usr/local/cuda-9.0/samples/common/inc" -I"/home/pcox/cuda-workspace/particle" -G -g -O0 -gencode arch=compute_30,code=sm_30 -odir “src” -M -o “src/particleSystem_cuda.d” “…/src/particleSystem_cuda.cu”
/usr/local/cuda-9.0/bin/nvcc -I"/usr/local/cuda-9.0/samples/5_Simulations" -I"/usr/local/cuda-9.0/samples/common/inc" -I"/home/pcox/cuda-workspace/particle" -G -g -O0 --compile --relocatable-device-code=false -gencode arch=compute_30,code=compute_30 -gencode arch=compute_30,code=sm_30 -x cu -o “src/particleSystem_cuda.o” “…/src/particleSystem_cuda.cu”
Finished building: …/src/particleSystem_cuda.cu

Building file: …/src/particles.cpp
Invoking: NVCC Compiler
/usr/local/cuda-9.0/bin/nvcc -I"/usr/local/cuda-9.0/samples/5_Simulations" -I"/usr/local/cuda-9.0/samples/common/inc" -I"/home/pcox/cuda-workspace/particle" -G -g -O0 -gencode arch=compute_30,code=sm_30 -odir “src” -M -o “src/particles.d” “…/src/particles.cpp”
/usr/local/cuda-9.0/bin/nvcc -I"/usr/local/cuda-9.0/samples/5_Simulations" -I"/usr/local/cuda-9.0/samples/common/inc" -I"/home/pcox/cuda-workspace/particle" -G -g -O0 --compile -x c++ -o “src/particles.o” “…/src/particles.cpp”
Finished building: …/src/particles.cpp

Building file: …/src/render_particles.cpp
Invoking: NVCC Compiler
/usr/local/cuda-9.0/bin/nvcc -I"/usr/local/cuda-9.0/samples/5_Simulations" -I"/usr/local/cuda-9.0/samples/common/inc" -I"/home/pcox/cuda-workspace/particle" -G -g -O0 -gencode arch=compute_30,code=sm_30 -odir “src” -M -o “src/render_particles.d” “…/src/render_particles.cpp”
/usr/local/cuda-9.0/bin/nvcc -I"/usr/local/cuda-9.0/samples/5_Simulations" -I"/usr/local/cuda-9.0/samples/common/inc" -I"/home/pcox/cuda-workspace/particle" -G -g -O0 --compile -x c++ -o “src/render_particles.o” “…/src/render_particles.cpp”
Finished building: …/src/render_particles.cpp

Building file: …/src/shaders.cpp
Invoking: NVCC Compiler
/usr/local/cuda-9.0/bin/nvcc -I"/usr/local/cuda-9.0/samples/5_Simulations" -I"/usr/local/cuda-9.0/samples/common/inc" -I"/home/pcox/cuda-workspace/particle" -G -g -O0 -gencode arch=compute_30,code=sm_30 -odir “src” -M -o “src/shaders.d” “…/src/shaders.cpp”
/usr/local/cuda-9.0/bin/nvcc -I"/usr/local/cuda-9.0/samples/5_Simulations" -I"/usr/local/cuda-9.0/samples/common/inc" -I"/home/pcox/cuda-workspace/particle" -G -g -O0 --compile -x c++ -o “src/shaders.o” “…/src/shaders.cpp”
Finished building: …/src/shaders.cpp

Building target: particle
Invoking: NVCC Linker
/usr/local/cuda-9.0/bin/nvcc --cudart static -L"/usr/local/cuda-9.0/samples/common/lib/linux/x86_64" -lGL -lGLU -lglut --relocatable-device-code=false -gencode arch=compute_30,code=compute_30 -gencode arch=compute_30,code=sm_30 -link -o “particle” ./src/particleSystem.o ./src/particleSystem_cuda.o ./src/particles.o ./src/render_particles.o ./src/shaders.o /usr/local/cuda-9.0/samples/common/lib/linux/x86_64/libGLEW.a
Finished building target: particle

14:14:10 Build Finished (took 18s.648ms)

15:44:20 **** Incremental Build of configuration Debug for project particle ****
make all
Building target: particle
Invoking: NVCC Linker
/usr/local/cuda-9.0/bin/nvcc --cudart static -L"/usr/local/cuda-9.0/samples/common/lib/linux/x86_64" -lGL -lGLU -lglut --relocatable-device-code=false -gencode arch=compute_30,code=compute_30 -gencode arch=compute_30,code=sm_30 -link -o “particle” ./src/particleSystem.o ./src/particleSystem_cuda.o ./src/particles.o ./src/render_particles.o ./src/shaders.o /usr/local/cuda-9.0/samples/common/lib/linux/x86_64/libGLEW.a
Finished building target: particle

15:44:20 Build Finished (took 819ms)

<< Stops >>

nvidia@tegra-ubuntu:~$ /bin/sh -c “cd “/home/nvidia/Documents/CudaProjects/Debug”;
export LD_LIBRARY_PATH=”/usr/local/cuda-9.0/lib64":${LD_LIBRARY_PATH};
export NVPROF_TMPDIR="/tmp";"/home/nvidia/Documents/CudaProjects/Debug/particle"";
exit
/bin/sh: 1: /home/nvidia/Documents/CudaProjects/Debug/particle: not found
logout

so it goes looking for the exe (particle) to run, but there’s nothing there.

So how come we’re building locally, rather than on the Jetson?
What am I setting up wrongly?
Any hints gratefully accepted!

Hi,

We have a Nsight tutorial for Jetson.
Could you check it first?

Thanks.