TK1 mounting SATA HDD softreset failed issue

Hi
On our TK1 platform system,we connected a HDD to TK1 via the standard built-in SATA connector and
we found that sometimes occurred HDD softreset failed issue.
1)The HDD device is HDD:SEAGATE 500GB
2)SW version:R21.4

“ata1: softreset failed” log information details as follow:
[ 7.218917] ALSA device list:

[ 7.221964] #0: HDA NVIDIA Tegra at 0x70038000 irq 113

[ 14.920410] ata1: softreset failed (1st FIS failed)

[ 20.433410] ata1: link is slow to respond, please be patient (ready=0)

[ 24.927407] ata1: softreset failed (device not ready)

[ 59.932404] ata1: softreset failed (1st FIS failed)

[ 59.937304] ata1: limiting SATA link speed to 1.5 Gbps

[ 65.143412] ata1: softreset failed (device not ready)

[ 65.148484] ata1: reset failed, giving up

who can tell me why sometimes the SATA devices fail completely after a couple of link attempts?

It is only some of them failed on HDD not all of boards.I tried different HDD and SSD device to crosscheck and the result is the same.

Hi, mywu1987,

There is routing layout guideline in OEM DG, did you follow that to do high speed line design? All your custom board are same design but only some of them failed on HDD, right? Did you try more HDD device to crosscheck? Is it possible interfered by other high speed signals? Also you can probe the signals with scope to check signal quality.

Hi kayccc,
Yes,we have follow to DG and high speed line design.And about 5% of our TK1 platform products that intermittently cannot detect the HDD drive in mass production.We found the good products are always good,but bad ones are always unstable.
we tried different HDD and SSD devices to crosscheck and the performance is the same.
Because of the scope bandwidth,we can’t test the eye diagram of SATA signals.
Can you pls give us some advcies?

It looks more like board issue, you can use X-ray and red ink to check if any non-wetting or solder short on balls of chip. This doc in DLC provides reflow profile: http://developer.nvidia.com/embedded/dlc/tk1-process-recommendation