TLT 3.0 Container Error while Convert to TFRecord

I’m trying to use bpnet from tlt. I loged in to docker and NGC both in virtualenv terminal and user terminal. Also when I tried to download nvidia-docker I get

2021-07-04 13:49:38,967 [INFO] root: Registry: ['']
2021-07-04 13:49:39,377 [WARNING] tlt.components.docker_handler.docker_handler: 
Docker will run the commands as root. If you would like to retain your
local host permissions, please add the "user":"UID:GID" in the
DockerOptions portion of the ~/.tlt_mounts.json file. You can obtain your
users UID and GID by using the "id -u" and "id -g" commands on the
Error response from daemon: Container 058772c954ca968af3103c72ee9218642419e4a404ac70e9132909a459a04951 is not running
2021-07-04 13:49:48,171 [INFO] tlt.components.docker_handler.docker_handler: Stopping container.
Traceback (most recent call last):
  File "/home/inovako/tlt/lib/python3.6/site-packages/docker/api/", line 259, in _raise_for_status
  File "/home/inovako/tlt/lib/python3.6/site-packages/requests/", line 941, in raise_for_status
    raise HTTPError(http_error_msg, response=self)
requests.exceptions.HTTPError: 404 Client Error: Not Found for url: http+docker://localhost/v1.41/containers/058772c954ca968af3103c72ee9218642419e4a404ac70e9132909a459a04951/stop

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/home/inovako/tlt/bin/tlt", line 8, in <module>
  File "/home/inovako/tlt/lib/python3.6/site-packages/tlt/entrypoint/", line 114, in main
  File "/home/inovako/tlt/lib/python3.6/site-packages/tlt/components/instance_handler/", line 278, in launch_command
  File "/home/inovako/tlt/lib/python3.6/site-packages/tlt/components/docker_handler/", line 299, in run_container
  File "/home/inovako/tlt/lib/python3.6/site-packages/tlt/components/docker_handler/", line 306, in stop_container
  File "/home/inovako/tlt/lib/python3.6/site-packages/docker/models/", line 436, in stop
    return self.client.api.stop(, **kwargs)
  File "/home/inovako/tlt/lib/python3.6/site-packages/docker/utils/", line 19, in wrapped
    return f(self, resource_id, *args, **kwargs)
  File "/home/inovako/tlt/lib/python3.6/site-packages/docker/api/", line 1167, in stop
  File "/home/inovako/tlt/lib/python3.6/site-packages/docker/api/", line 261, in _raise_for_status
    raise create_api_error_from_http_exception(e)
  File "/home/inovako/tlt/lib/python3.6/site-packages/docker/", line 31, in create_api_error_from_http_exception
    raise cls(e, response=response, explanation=explanation)
docker.errors.NotFound: 404 Client Error: Not Found ("No such container: 058772c954ca968af3103c72ee9218642419e4a404ac70e9132909a459a04951")

And TLT info is

Configuration of the TLT Instance
dockers: [‘nvidia/tlt-streamanalytics’, ‘nvidia/tlt-pytorch’]
format_version: 1.0
tlt_version: 3.0
published_date: 04/16/2021

What do you mean by "when I tried to download nvidia-docker "? Can you share the command?

And where did you install tlt-launcher? Jetson devices or host PC?

Hi Morganh,

I made all installations on device. I don’t use headless device mode so much. I enter to terminal curl | sh \ && sudo systemctl --now enable docker and It gives “ InRelease …” signature invalid error

Please install tlt-launcher and run training on host PC instead.
After training, if we deploy the model and run inference, it can be host PC or Jetson devices.

Related topic: Converting Tfrecords for kitti trainval dataset - #2

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.