Tracking with Dlib in Jetson TX2 slower than Nano

Hi all,

I have a program doing detection and tracking of moving vehicles with some statistics visualization. The program is well optimized to work in real-time on Jetson Nano (using TensorRT engine for detection). I moved the same code + models from Nano to TX2 with generating new engine files. The program runs 5-6 times slower than Nano. Normally TX2 has 2 additional Denver CPUs and is supposed to be faster. I measure the processing time for detection and tracking. Detection Time is similar, but the tracking with Dlib is slower. I m using the correlation tracker in Dlib.

Environment (for both TX2 and Nano):

  • Jetpack L4T 32.2.1
  • GPU ARCH (6.2 TX2) / (5.3 Nano)
  • OpenCV 4.1.1 compiled CUDA YES (Compiled from source in a 128GB SD card (TX2) / internal storage (Nano))
  • TensorRT 5.1.6.1
  • Dlib 19.17 (Compiled from source in internal storage)
  • Matplotlib 2.1.1 (installed with pip3)
  • CUDA 10.0.326
  • cuDNN 7.5.0.56
  • VisionWorks 1.6.0.500n
  • Python 3.6.8

Things I tried and failed :

Are there any ideas, i can try to fix this issue?

Thanks in advance

Hi,

Do you setup the Nano and TX2 from the same JetPack installer?
If yes, you should get the similar performance since the software version is identical.

It looks like you try to setup the nvpmodel but no jetson_clocks?
If yes, would you mind to give it a try.
This script maximize the CPU/GPU clocks and improve the performance.

sudo jetson_clocks

Thanks.

Hi AastaLLL,

Thanks a lot for your reply.
No, we setup the Nano with SD card image, and TX2 via SDK Manager installed on an Ubuntu18 VMware machine. Can flashing with VMware create issues? even if it was done successfully?

We tried all nvpmodel modes, with jetson_clock, but no significant improvement so far. Also in The Nano, we are not using the jetson_clocks.

BR

Hi elbouziadyabderrahim,

" Can flashing with VMware create issues?" --> probably, due to some unknown reason, and the VM is not suggested for developing.

Yep, you were right, it creates issues. we flashed and installed everything from scratch using a laptop with native Ubuntu. Now it is working. Thanks