Trying To Enable Wakeup On GPIO10 Jetpack 5.1.1 Orin-NX

Hi Nvidia,

I am trying to enable GPIO 10 as a wakeup pin in L4T 35.3.1 for Orin-NX.
My current device tree setting is:

My pinmux entry for gpio 10:

Note that I can detect the gpio reading change in /sys/kernel/debug/gpio:

But I am not seeing the interrupt being thrown in /proc/interrupts:

and the system will not come back on after using:
systemctl suspend
Is there anything I am forgetting here?



Hi mfischer,

What’s your carrier board for Orin-NX?

Have you tried to refer the following instruction to configure interrupt?
GPIO Interrupt Mapping Configuration — Jetson Linux Developer Guide documentation (

Hi Kevin,

Thanks for the feedback I appreciate it!

I did implement the changes in bootloader/t186ref/BCT for the gpio-int dts and was able to get the interrupt to work while the orin-nx was running (not in sleep mode). When I push the button we have on PEE.02, I get the power off prompt from Ubuntu saying that the system will restart automatically in 60 seconds, which is to be expected.

I however still cannot get the system to wakeup using PEE.02.
This is a custom board, I am working with although we also implement the regular wakeup pin utilized in the devkit PEE.04 (the sleep/wake pin). I manually shorted this pin and saw the same power off prompt from Ubuntu and after running systemctl suspend was able wake the device.

There must be one more step that is being missed here in order to enable that pin for wakeup…
Let me know if there is anything else I should try.



There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.

Do you have the devkit could be reproduced for the same behvior?