Tutorial : Install NVIDIA 396.24 in Fedora 28 with Kernel 4.16.x


It’s pointless to help people on this site.

So here is my issue:

After the login screen appears, I can not use Ctrl+Alt+F3. Actually no VTs work. I have tried different keyboards, but it just won’t work. Any solution?

I followed the bottom section of the reference guide and used systemctl set-default multi-user.target to boot into level 3.

Once logged in and navigating to the executable, I ran it with sudo and it prompted “Failed to install kernel moduoe through DKMS” just as before.
I can reload a recent backup and try anything you suggest.
Thanks for sharing your guide anyways, great work, if it worked. I followed it closely until the above issue. Anything else I can try?



Okay, will do that. Thanks for the quick reply! :)

Actually I’ve tried all combinations with Fn, Windows, Ctrl, Alt key and 3. It is a mystery to me as well :D

I selected dkms, because it was selected in the reference guide as well. Maybe the installation would not fail, when I do not choose DKMS. Will try that in ~ a week. Can not access my computer for now. I will report my experience once I am back home :)


I tried to reload my backup and it failed. I spent roughly 80 hours on this reinstalling and reconfiguring every single time and seeing all of that time go to waste is very depressing. I am at a point, where I wish I would have just stuck with nouveau. I will however give it one more try, just because of your efforts :D

I will freshly install fedora and do exactly your steps above. Will report the experience.

Here is my issue:
Display Manager Switching Tool won’t launch.
When executing from command line I get the following output:

No protocol specified
/usr/lib64/python2.7/site-packages/gtk-2.0/gtk/init.py:57: GtkWarning: could not open display
warnings.warn(str(e), _gtk.Warning)

I had similar issues with Fedy once, where applications executed with sudo-priveleges could not create a GUI instance. Looking for a fix for that first.


Seems to be an authentication issue.

[root@localhost darkn]# echo $XAUTHORITY

[root@localhost darkn]# exit
[darkn@localhost ~]$ echo $XAUTHORITY

I added export XAUTHORITY=~/.Xauthority to my .bashrc, will reboot and check if that works.

Nope it didn’t. Also transfering priveleges from regular user to root didn’t work.
So I just went into terminal-mode and executed

sudo systemctl disable gdm
sudo systemctl enable lightdm
sudo systemctl stop gdm
sudo systemctl start lightdm

Guess that works too. Will continue from here on.

Do NOT follow this guide because each time you’re going to upgrade X.org your system will become dysfunctional.

Oh and btw:

With the fresh installation Ctrl+Alt+F3 works just fine.

Now I am excited. Will install now.

Okay, why should that be?
And what do you recommend then?

Alright, I give up. Wasted the whole day again.
Switching to ubuntu.

This guide is complete bullcrap.

Normal people just copy and paste two lines:

dnf install https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm https://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm
dnf install xorg-x11-drv-nvidia akmod-nvidia

Those guys know what they’re doing. Install scripts automatically disable nouveau and stuff and it has automatic updates for new kernels and stuff.

(No idea about conflicts with specific desktop environments, so there may indeed be additional steps for gnome/cinnamon/whatever; but the whole original post is silly, like commands not working on tty2 but working on tty3, wtf? :))

I’m leaving this here for future poor souls who will also break their systems and go to Ubuntu because someone leaves bad instructions.


I have used it till the earlier time and nothing has happened to me. Why will that happen?


Sadly the only thing that happened was, that I got a new login-prompt (I assume lightdm). When I tried to login with it the screen froze.

Umm, suuuuure.

I viewed it multiple times and it never worked for me or anyone else. Unless by “worked for them” you meant “made them frustrated from super bad advice” :/

Btw, this thread has actual ZERO confirmation responses. Only replies are 1. people warning others of following this crap and 2. people who followed this crap and ended up switching to Ubuntu.

For future viewers: you don’t need to install Ubuntu. Fedora actually does have an awesome system of installing and updating Nvidia drivers. Simply avoid this guy’s silly advice and you’ll be fine.

Deleted. Happy now? Go and help other people yourself with your mind-blowing technical skills.

I’m out of this forum.

The ubuntu guy again:

I tried your suggested way and it didn’t work in the first place, so I started to look for different solutions.
Only Fedora 28 has caused these problems for me. I never had any issues with 24-27 and don’t know why.

So for other people who stumble upon this thread: please give a detailed description on what to do, as I can not. :)