tx2 disable service issue

Hi NV people

i want to disable service all the time.
i can use “systemctl stop” and “systemctl disable” to close the service.
but after reboot the service is always running.

i can use rm /etc/init.d to remove service but i think it is not a normal step
how to turn off the service?

It depends on which service. Which service do you want to stop? Mostly this is the same as other Ubuntu, but there are some differences when it comes to graphical login services (I see this as a bug in L4T).

hi linuxdev

i try to turn off the avahi-daemon but after reboot this daemon still running.

could you share the correct step?

I am uncertain about this. I believe this is started during any GUI login. Some GUI login control via systemctl is non-standard in L4T, although I couldn’t say exactly how. The gist is that using systemctl to disable a GUI login is different than the steps required to do so on a PC Ubuntu. I suspect what you are running into could be part of that if systemctl cannot do a normal disable.

If nobody is logged in to the GUI, and you have used a serial console or ssh login (or CTRL-ALT-F2), what does this do?

sudo systemctl disable avahi-daemon.service
sudo systemctl list-unit-files | grep -i avahi

You may find this of interest since I believe it is the GUI running which triggers the restart even after a disable:
…basically it says to “sudo systemctl mask avahi-daemon.service” instead of disable. Only auto start goes away upon disable…mask actually bans.

Hi linuxdev

i can use mask command to disable the service.

thanks for your suggestion.