TX2i How do I turn off the DVI internal DDC

Now we need to optimize the system startup time of TX2i, and it takes a long time to check the startup information of DVI-DDC.We consider turning off dVI-DDC in TX2i to optimize the startup time.How do we turn off the DDC function?

Hi,

Actually, TX2 does not support DVI… are you using a DVI to HDMI adapter here?

Yes, we implemented the DVI output via HDMI to DVI.

Could you show the log for us to know the exact delay or error?

Hi,
The following is TX2i start printing information, please help to see where we can also optimize the start time? What we analyzed is that the DDC in the main HDMI takes a long time.
Please check the attached tx2i_log.txt file:
tx2i_log.txt (82.6 KB)

Hi,

[ 7.852161] tegradc 15220000.nvdisplay: hdmi: edid read failed
[ 7.852189] tegradc 15220000.nvdisplay: hdmi: using fallback edid

The monitor does not read edid from your monitor at all. It is using hard-coded value we wrote in driver.

You can only try the method "Forcing edid " in below.

If you force an EDID according to the method you provided above, will the system boot to read the EDID of the currently connected display device over and over again?Directly read the EDID for load force Settings?

It will not read the connected device.

Hi
Tx2i_log.txt in the attachment is the information output by the system terminal during the startup of TX2I module.Why does it take 17 seconds to boot UBOOT, and 20 seconds or so for the operating system to boot, but nearly 20 seconds before UBOOT? Is there anything you can do to reduce the time before UBOOT?TX2i_log(9.25).txt (103.5 KB)

Not related to current issue. Please file a new topic.