UART port setting and behavior

Hi Man,

There are 2 UARTS ports on Xavier Jetson NX. It 4-wire design.
And I would like know that the behavior of TX and RTS.
As I know TX is low active when data transmitted.

If you enabled UART function, which RTS behavior is yours? ( I means correct one)
Is upper one waveform or lower one waveform?

I think I will check which behavior is correct first, then I will follow the setting you post.


It is RTS_N, low for enable.


So, it should be that, right?

I measure our RTS signal on UART0 and UART1, it always be high.
So I think there are something wrong in software setting.
Therefore, I will check the FW setting with you step by step.
By the way, I’m not a software side engineer, so if possible, please kindly describe it more detail to let me know how to adjust.
I will post any software setting , and I wish I can get the same behvior with yours after this discussion finished.

This step I want to check the GPIO table is correct or not.
Here are my current setting. Should something be modified?

UART0_TXD 99 UART2_TX GPIO3_PX.04 UB3_TXD ram_code3 100k pd UB3_TXD Output Disable Disable UART0_TX
UART0_RXD 101 UART2_RX GPIO3_PX.05 UB3_RXD 100k pd UB3_RXD Input Disable Disable UART0_RX
UART0_RTS* 103 UART2_RTS GPIO3_PX.06 UB3_RTS ram_code2 100k pd UB3_RTS Output Int PU Disable UART0_RTS*
UART0_CTS* 105 UART2_CTS GPIO3_PX.07 UB3_CTS wake52 100k pu UB3_CTS Input Int PU No Disable UART0_CTS*

And I think


There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.

Hi allison_chen,

Are you using the devkit or custom board for Xavier NX?
What’s your Jetpack version in use?

If you want to use hw flow control for UART, you should enable the either flag as following:

  1. termios(3) - Linux manual page
    CRTSCTS → this is the termios flag to enable/disable HW FLow control.
  2. pySerial API — pySerial 3.4 documentation
    If you are using python, then you can enable rtscts flag.

Could you share the block diagram of connection?
It seems you are using uartb@3110000 to communicate with the UART device.
What UART device are you using?