Ubuntu 18 NVRM: Xid 6,12,13,69 at old hardware

Hello All,

Not sure it is right place for posting this. Excuse me if it is so.

Errors in dmesg:
NVRM: Xid (PCI:0000:08:00): 6, PE0008
NVRM: Xid (PCI:0000:08:00): 12, COCOD 00000002 e0012d00 0000502d 00000864 ffffffff
NVRM: Xid (PCI:0000:08:00): 13, Graphics Exception: ChID 0010, Class 00008397, Offset 00000e08, Data 04380000
NVRM: Xid (PCI:0000:08:00): 69, Class Error: ChId 000e, Class 0000502d, Offset 00000250, Data ffffffff, ErrorCode 0000000c

I got this errors via executing command “grep -R “NVRM: Xid” /var/log/” and copying/pasting unique errors here.
Errors comes randomly, but always starts from error 13, and after error 13 I see 69 with 6 or 12 or all together. System finaly hangs, and I should reset it.

Looks like fix is in adding intel_iommu=off to kernel boot parameters.

eVGA GTX 260
mobo S5000XVN final bios (support is EOL-ed)

root@S5000XVN:/var/log# modinfo nvidia
filename: /lib/modules/5.4.0-42-generic/updates/dkms/nvidia.ko
alias: char-major-195-*
version: 340.108
supported: external
license: NVIDIA
alias: pci:v000010DEd00000E00svsdbc04sc80i00*
alias: pci:v000010DEd00000AA3svsdbc0Bsc40i00*
alias: pci:v000010DEdsvsdbc03sc02i00
alias: pci:v000010DEdsvsdbc03sc00i00
depends: drm
retpoline: Y
name: nvidia
vermagic: 5.4.0-42-generic SMP mod_unload
parm: NVreg_Mobile:int
parm: NVreg_ResmanDebugLevel:int
parm: NVreg_RmLogonRC:int
parm: NVreg_ModifyDeviceFiles:int
parm: NVreg_DeviceFileUID:int
parm: NVreg_DeviceFileGID:int
parm: NVreg_DeviceFileMode:int
parm: NVreg_RemapLimit:int
parm: NVreg_UpdateMemoryTypes:int
parm: NVreg_InitializeSystemMemoryAllocations:int
parm: NVreg_UsePageAttributeTable:int
parm: NVreg_MapRegistersEarly:int
parm: NVreg_RegisterForACPIEvents:int
parm: NVreg_CheckPCIConfigSpace:int
parm: NVreg_EnablePCIeGen3:int
parm: NVreg_EnableMSI:int
parm: NVreg_MemoryPoolSize:int
parm: NVreg_RegistryDwords:charp
parm: NVreg_RmMsg:charp
parm: NVreg_AssignGpus:charp
root-S5000XVN:/var/log# uname -a
Linux S5000XVN 5.4.0-42-generic #46~18.04.1-Ubuntu SMP Fri Jul 10 07:21:24 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

xserver-xorg-core-hwe-18.04 2:1.20.8-2ubuntu2.2~18.04.1

After plaing few days with this card I decided change OS to Win7. Got near same error (0x00000124) pointing me to problems with hardware.

Final conclusion in my case - it is hardware problem.

How I fixed it (probably temporary): I disassembled card and heat up chip for 5-10 mins at 200-250C. Now FurMark does not crash system. Will try to play some games, while I am at Win7 ;)