Ubuntu 22.04 black screen showing input not supported after installing the nvidia driver


I’m stucking on the installation of nvidia driver on Ubuntu 22.04 LTS.
I’m using a non-hybrid desktop which is 10700K with Z490I and 3080 12g. I have tried many tutorials, but I always got a black screen with displaying "input not supported ".

At first, I have tried the following command

sudo ubuntu-drivers autoinstall

the system chose 515 driver for me, but i got a black screen after rebooting
Then I booted to another kernel and remove the 515 driver and switch back to nouveau driver.

I read a tutorial by executing the runfile. I have added the nouveau to the blacklist, installed the lightdm, switched to telinit 3 for text mode, stopped the lightdm service, and execute the runfile. However, I still got a black screen with displaying the same words.

When I press ctrl+alt+f3, I still got a black screen with displaying the same words.
Thus, the bug report was captured by connecting with ssh.

Hope some one can help me fix this, thx.

nvidia-bug-report.log.gz (265.1 KB)

Iḿ with the same issue at popOS

Configurando nvidia-dkms-390 (390.151-0ubuntu0.22.04.1) …
update-initramfs: deferring update (trigger activated)
INFO:Enable nvidia
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/lenovo_thinkpad
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/dell_latitude
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/put_your_quirks_here
Removing old nvidia-390.151 DKMS files…
Deleting module nvidia-390.151 completely from the DKMS tree.
Loading new nvidia-390.151 DKMS files…
Building for 5.18.10-76051810-generic
Building for architecture x86_64
Building initial module for 5.18.10-76051810-generic
ERROR (dkms apport): kernel package linux-headers-5.18.10-76051810-generic
is not supported
Error! Bad return status for module build on kernel: 5.18.10-76051810-gener
ic (x86_64)
Consult /var/lib/dkms/nvidia/390.151/build/make.log for more information.
dpkg: error al procesar el paquete nvidia-dkms-390 (–configure):
el subproceso instalado paquete nvidia-dkms-390 script post-installation d
evolvió el código de salida de error 10
dpkg: problemas de dependencias impiden la configuración de nvidia-driver-3
nvidia-driver-390 depende de nvidia-dkms-390 (<= 390.151-1); sin embargo:
El paquete nvidia-dkms-390' no está configurado todavía. nvidia-driver-390 depende de nvidia-dkms-390 (>= 390.151); sin embargo: El paquete nvidia-dkms-390’ no está configurado todavía.

dpkg: error al procesar el paquete nvidia-driver-390 (–configure):
problemas de dependencias - se deja sin configurar
No se escribió un informe «apport» porque el mensaje de error indica que es
un mensaje de error asociado a un fallo previo.
Procesando disparadores par
a initramfs-tools (0.140ubuntu13) …
update-initramfs: Generating /boot/initrd.img-5.18.10-76051810-generic
cryptsetup: WARNING: Resume target cryptswap uses a key file
kernelstub.Config : INFO Looking for configuration…
kernelstub : INFO System information:

OS:..................Pop!_OS 22.04
Root partition:....../dev/dm-1
Root FS UUID:........9b85b929-6784-4a48-96bc-54e88ad70ae4
ESP Path:............/boot/efi
ESP Partition:......./dev/sda1
ESP Partition #:.....1
NVRAM entry #:.......-1
Boot Variable #:.....0000
Kernel Boot Options:.quiet loglevel=0 systemd.show_status=false splash
Kernel Image Path:.../boot/vmlinuz-5.18.10-76051810-generic
Initrd Image Path:.../boot/initrd.img-5.18.10-76051810-generic

kernelstub.Installer : INFO Copying Kernel into ESP
kernelstub.Installer : INFO Copying initrd.img into ESP
kernelstub.Installer : INFO Setting up loader.conf configuration
kernelstub.Installer : INFO Making entry file for Pop!_OS
kernelstub.Installer : INFO Backing up old kernel
kernelstub.Installer : INFO Making entry file for Pop!_OS
Se encontraron errores al procesar:
E: Sub-process /usr/bin/dpkg returned an error code (1)

@jeremylyz Same monitor:

Please try using a DisplayPort cable or try downgrading the driver.

Is this a bug problem or compatibility problem ?

similar problem but for ubuntu

@xiangruhuang a little bit of both, I guess. Something in the monitor’s firmware triggers the nvidia driver to switch to hdmi 2.0 while the monitor only supports hdmi 1.4. Since this wasn’t the case with an earlier driver, this is hopefully fixed/worked around in a newer driver release.
It’s also advisable to check if dell provides a firmware update for the monitor.

I have tried on 18.04 with 515 drivers. While using gdm3, it shows input not supported. But if using lightdm, it will be fine. Is there some compatibility problems with gdm3?

The graphics system is driven by the Xserver but gdm also has a monitor manager. Might be it set a not supported resolution though that’s very unlikely.

It did work after changing a dp cable, many thx

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.