The screen of laptop is black after installing nvidia 495.44 driver on ubuntu 20.04

Hi experts,

I installed nvida 495.44 driver from the Additional drivers in Update-manager and got the black screen on ubuntu 20.04.

I can ssh into ubuntu and nvidia-smi is working fine.

nvidia-smi

Wed Dec 8 19:20:36 2021
±----------------------------------------------------------------------------+
| NVIDIA-SMI 495.44 Driver Version: 495.44 CUDA Version: 11.5 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
| | | MIG M. |
|===============================+======================+======================|
| 0 Quadro T1000 Off | 00000000:01:00.0 On | N/A |
| N/A 44C P8 6W / N/A | 120MiB / 3878MiB | 0% Default |
| | | N/A |
±------------------------------±---------------------±---------------------+

±----------------------------------------------------------------------------+
| Processes: |
| GPU GI CI PID Type Process name GPU Memory |
| ID ID Usage |
|=============================================================================|
| 0 N/A N/A 845 G /usr/lib/xorg/Xorg 110MiB |
| 0 N/A N/A 1065 G /usr/bin/gnome-shell 7MiB |
±----------------------------------------------------------------------------+

I tried everything but got no luck. After removing nvidia-driver and using nouveau, the screen is normal. But I really need the screen be lighted using nvidia driver.

Can some one help on this. I have attached the nvdia-bug-report.log.

Thx in advance

nvidia-bug-report.log.gz (293.4 KB)

This is a hybrid graphics notebook, the internal display is driven by the igpu which you’re killing with the nomodeset parameter.

  • uninstall the runfile driver
  • install the repo driver using Software&Updates
  • remove the nomodeset parameter

Thx @generix, I just removed all the 495 driver and installed the 470 (proprietary, tested) from Software & Update. and I also removed the nomodeset parameter, and got the same thing, no display.

Attached the newest report. Could you help to check it again? Really thx

nvidia-bug-report.log.gz (291.2 KB)

Did you switch gpus in bios? The intel gpu seems to be gone.

@generix, Thx. Seems yes. Since I’ve changed from Hybrid Graphics to Discrete Graphics.

BTW, I tried to install 460 driver, it worked.

Same issue here. Discrete graphics mode.
460 driver is working fine.
For 470 / 495 laptop internal display is black screen, while external usb-c to displayport works fine. During wakeup from suspend, there are console text flashing on internal display. After fully wakeup, it’s black screen.
nvidia-bug-report.log.gz (655.8 KB)

1 Like

Please try setting kernel parameter
nvidia.NVreg_RegistryDwords=EnableBrightnessControl=1

nvidia.NVreg_RegistryDwords=EnableBrightnessControl=1 makes no difference, still black screen

issue resolved with 510.47.03 driver

1 Like

Thx for the information.