Ubuntu 22 uses llvmpiper as renderer instead of nvidia

Hello, excuse my English.

I have a problem with this PC, it was not used for a while, when I updated it problems started. It when from Ubuntu 18.04 to Ubuntu 20.04, then to 22.04.
The main issue are persistant black screens who appears in certain occasion and some little artefacts (just pixel). The Grapich card is correctly installed and it has enough power. I tried to investigate and I have seen this:

$ glxinfo -B
name of display: :1
display: :1  screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: Mesa/X.org (0xffffffff)
    Device: llvmpipe (LLVM 15.0.6, 256 bits) (0xffffffff)
    Version: 22.2.5
    Accelerated: no
    Video memory: 7890MB
    Unified memory: no
    Preferred profile: core (0x1)
    Max core profile version: 4.5
    Max compat profile version: 4.5
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.2
OpenGL vendor string: Mesa/X.org
OpenGL renderer string: llvmpipe (LLVM 15.0.6, 256 bits)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 22.2.5
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 4.5 (Compatibility Profile) Mesa 22.2.5
OpenGL shading language version string: 4.50
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile

OpenGL ES profile version string: OpenGL ES 3.2 Mesa 22.2.5
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
$ inxi -G
  Device-1: NVIDIA GP107 [GeForce GTX 1050 Ti] driver: nvidia v: 535.86.05
  Display: wayland server: X.Org v: with: Xwayland v: 22.1.1
    compositor: gnome-shell v: 42.5 driver: X: loaded: nvidia
    unloaded: fbdev,modesetting,nouveau,vesa gpu: nvidia
    resolution: 1920x1080~60Hz
  OpenGL: renderer: llvmpipe (LLVM 15.0.6 256 bits) v: 4.5 Mesa 22.2.5

I tried to reinstall drivers but it didn’t fix the problem, it still renders with llvmpipe.

Processor: AMD FX™-8320