Ubuntu 7.10 and multi GTX280's GPU's not recognised!

Hi all,

I’ve got a system running 32bit Ubuntu7.10 on an XFX nForce 790i Ultra mobo with 3 graphics cards installed. Two cards are GTX280’s (which I want to use for CUDA, in 1st and 2nd PCIe slots) and the third is a FX5200 (for display only, in 3rd PCIe slot).

The system recognises the FX5200 and the display works as expected but I cannot get the system to recognise the GTX280’s. I’ve installed the Nvidia drivers for the cards (NVIDIA-Linux-x86-173.14.12-) as recommended on the Nvidia GeForce GTX280 webpage pages but querying the PCI devices yeilds:

$ lspci | grep -i nvidia
01:00.0 VGA compatible controller: nVidia Corporation Unknown device 05e1 (rev a1)
02:00.0 VGA compatible controller: nVidia Corporation Unknown device 05e1 (rev a1)
03:09.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX5200] (rev a1)

Installing the CUDA drivers (NVIDIA-Linux-x86-177.67-) as recommended on the ‘get CUDA’ pages doesn’t rectify the problem, the GTX280’s are still unrecognised in PCIe 01 and 02 and, of course, the FX5200 isn’t supported by this driver as it’s seen as a legacy device so the X-server crashes horribly!

Does any one have any experience with, or advice on, encouraging linux and GTX280’s to get along happily together, or setting up a multi GPU platform of this type/combination of GPU’s?

Thanks, in advance, for your help.


lspci output has no association with driver functionality.

However, your FX5200 will not work in the same nvidia driver as the GTX280’s, as its a legacy GPU. You can’t run X with this combination of hardware.

Good info - What’s the oldest / cheapest non-legacy series? Geforce 7? Thanks.

There might be a really ugly workaround to get the 5200 and GTX 280s running on the same machine, though. Note that this is totally unsupported, nobody from NVIDIA will answer any questions you have about it because none of us have tried it and it’s probably a terrible idea, your machine might turn into a chunk of strange matter and consume the Earth, etc. If you install the 177.67 driver, only have an entry for your 5200 in xorg.conf, and use the nv driver (or maybe even Nouveau? I’ve never used it, so I don’t know anything about it) alongside the old initialize /dev/nvidia* script, I think you could get CUDA on the GTX 280s alongside the 5200 in X.

If you attempt that, you are a braver man than I.

Hi all,

Thanks for your replies to my question!

So, even though lspci returns an ‘unknown device’ message for the two cards in PCI01 and 02 this doesn’t mean that the cards don’t (or won’t) work, just that the system doesn’t know what they are? Assuming I have the right drivers installed they should be able to run CUDA despite their unknown device status, right (but, of course, I won’t get a display since the FX5200 won’t be recognised)?

I think updating the display gpu to something that is supported by the GFX280 drivers but which isn’t CUDA enabled sounds like the easiest solution.



Unknown device from the output of lspci means that there is no entry in the pci-id list ( /usr/share/hwdata/pci.ids ) for that card.
Once you load the right driver, it will work just fine

Hello, I am also having a similar problem – I have a motherboard with embedded graphics (750 series), and I want to use the embedded graphics for my display, but I want to add an 8800GT in the PCIE slot, but I only want to use that card for CUDA.

When I install the driver (177.67), it says that it installed correctly, but then when I reboot it never starts X. When I have my display attached to the card itself it works. I have made sure the bios was set to keep both enabled. I have tried placing another “device” section for videocard1 in xorg.conf, set to use the nvidia driver, but it still doesn’t work. Does the nvidia Linux-64 driver only allow one card, or if it allows two, do they have to be in SLI mode, or maybe it doesn’t allow one of them to be embedded in the MB?


Your X configuration & your driver installation’s correctness determine whether X will run with a specific hardware setup. There are no GPU enumeration or SLI limitations.

Thanks, but X will simply not find the display when there is more than one enabled GPU, regardless of which port I have it plugged into.

By the way, as for the original problem posted here, I was just on the phone with some very good nvidia CUDA support people and they informed me that in order for CUDA to work, ALL GPUs must be capable of running CUDA, even if one is not planning on using the older card for CUDA processing – the driver will simply not work for that. So perhaps one would want to purchase the cheapest possible CUDA compatible card for such a purpose.

However, in my case I really do have both CUDA compatible cards and it still doesn’t work. I’m still not 100% sure it isn’t a bios problem, or a driver problem, or some config problem, but I would expect this last one would have been fixed by the nvidia driver install since I let it modify xorg.conf.

Has anyone out there run their display from the motherboard and run their CUDA processing on a PCIE card?

They gave you wrong information, you don’t need to have all CUDA capable GPUs in order for CUDA to work under Linux. You just need to create the right /dev entries and load the right module ( look at the release note for CUDA 1.1, there is a script to do that) if all you want to do is use those GPUs for computing. Graphic interops may not work, but if your application is just crunching numbers, it will work just fine.