one CUDA card unrecognized in 64bit Win7

I have 2 CUDA cards installed, one C1060 (device 0), the other GT430. Both of them work in Linux. However, in 64bit Win7, only C1060 is recognized as shown in deviceQuery’s results.

Note it’s in TCC mode. Anyone knows how to fix it? Thanks.

Edit: Both cards can be seen in Device Manager.

Here is the Linux result:

In both systems, I’m using latest 4.0 RC2 softwares and developer drivers.

Actually I have a third video card (Matrox G200eW) on the same workstation, which is not CUDA and used for display. Could it be the problem?

Yes indeed, that could be the problem.

I had the same problem on my machine. Try to plugin the monitor to the GTX card in see if it detects booth.

The tesla card works because it is in TCC mode. If you disable the TCC from the tesla not event this card will be recognized as a CUDA device.

Thanks brano. Using your method, I fixed the problem (see new Win7 results below). But before plugging the monitor into the GT430 card, some steps are needed. These include disabling onboard card driver in safe mode and setting boot video card priority in BIOS [BIOS -> Advanced -> PCI/PnP Configuration -> Boots Graphic Adapter Priority -> Select “Slot 6” instead of previous “Onboard VGA” (the NVIDIA GT430 card is on slot 6)].

The monitor does not plug into the card and the card is not recognized. This sounds like a bug. Anyway Linux has no this problem. NVIDIA may want to fix it.