why "all CUDA-capable devices are busy or unavailable" ?

Thinkpad T410 RT9

Core i5 520M + 4G Memory + NVS 3100M

ArchLinux x86_64

cuda-sdk & cuda-toolkit installed

I can execute deviceQuery to get the following info:

but when I execute the cuda program, then it give me the error msg:

any body can help on this ?

Have you set the device to prohibited or exclusive mode with nvidia-smi for some reason?

http://developer.download.nvidia.com/compu…6292f1ffbe.html

the deviceQuery program tell me that :

Compute mode: Default (multiple host threads can use this device simultaneously)

you can get this from my post msg.

or do you think the deviceQuery’s result is not very precise ?

after I restart my machine. the app runs normally. looks like some bugs in the driver ?

if you use kde try to suspend and resume composition in kwin.

I am experiencing this same problem. Installation of the 260.19.14 driver and cudatoolkit_3.2.12_linux_64_rhel5.5 and gpucomputingsdk_3.2.12_linux all seems fine under RHEL 5.5. deviceQuery properly shows my GTX 285, yet any application from the SDK gives an error as follows. In my case, I have restarted and reinstalled several times, and still have the same problem.

The error appears:

Running on...

Device 0: GeForce GTX 285

 Quick Mode

bandwidthTest.cu(598) : cudaSafeCall() Runtime API error : all CUDA-capable devices are busy or unavailable.

deviceQuery shows:

./deviceQuery Starting...

CUDA Device Query (Runtime API) version (CUDART static linking)

There is 1 device supporting CUDA

Device 0: "GeForce GTX 285"

  CUDA Driver Version:                           3.20

  CUDA Runtime Version:                          3.20

  CUDA Capability Major/Minor version number:    1.3

  Total amount of global memory:                 1073020928 bytes

  Multiprocessors x Cores/MP = Cores:            30 (MP) x 8 (Cores/MP) = 240 (Cores)

  Total amount of constant memory:               65536 bytes

  Total amount of shared memory per block:       16384 bytes

  Total number of registers available per block: 16384

  Warp size:                                     32

  Maximum number of threads per block:           512

  Maximum sizes of each dimension of a block:    512 x 512 x 64

  Maximum sizes of each dimension of a grid:     65535 x 65535 x 1

  Maximum memory pitch:                          2147483647 bytes

  Texture alignment:                             256 bytes

  Clock rate:                                    1.48 GHz

  Concurrent copy and execution:                 Yes

  Run time limit on kernels:                     Yes

  Integrated:                                    No

  Support host page-locked memory mapping:       Yes

  Compute mode:                                  Default (multiple host threads can use this device simultaneously)

  Concurrent kernel execution:                   No

  Device has ECC support enabled:                No

  Device is using TCC driver mode:               No

deviceQuery, CUDA Driver = CUDART, CUDA Driver Version = 3.20, CUDA Runtime Version = 3.20, NumDevs = 1, Device = GeForce GTX 285

PASSED

And nvidia-smi shows:

nvidia-smi -a

==============NVSMI LOG==============

Timestamp                       : Thu Nov 11 15:08:03 2010

Driver Version                  : 260.19.14

GPU 0:

        Product Name            : GeForce GTX 285

        PCI Device/Vendor ID    : 5e310de

        PCI Location ID         : 0:3:0

        Display                 : Connected

        Temperature             : 45 C

        Fan Speed               : 40%

        Utilization

            GPU                 : 0%

            Memory              : 1%

Any suggestions?

Thanks,

G

I am experiencing this same problem. Installation of the 260.19.14 driver and cudatoolkit_3.2.12_linux_64_rhel5.5 and gpucomputingsdk_3.2.12_linux all seems fine under RHEL 5.5. deviceQuery properly shows my GTX 285, yet any application from the SDK gives an error as follows. In my case, I have restarted and reinstalled several times, and still have the same problem.

The error appears:

Running on...

Device 0: GeForce GTX 285

 Quick Mode

bandwidthTest.cu(598) : cudaSafeCall() Runtime API error : all CUDA-capable devices are busy or unavailable.

deviceQuery shows:

./deviceQuery Starting...

CUDA Device Query (Runtime API) version (CUDART static linking)

There is 1 device supporting CUDA

Device 0: "GeForce GTX 285"

  CUDA Driver Version:                           3.20

  CUDA Runtime Version:                          3.20

  CUDA Capability Major/Minor version number:    1.3

  Total amount of global memory:                 1073020928 bytes

  Multiprocessors x Cores/MP = Cores:            30 (MP) x 8 (Cores/MP) = 240 (Cores)

  Total amount of constant memory:               65536 bytes

  Total amount of shared memory per block:       16384 bytes

  Total number of registers available per block: 16384

  Warp size:                                     32

  Maximum number of threads per block:           512

  Maximum sizes of each dimension of a block:    512 x 512 x 64

  Maximum sizes of each dimension of a grid:     65535 x 65535 x 1

  Maximum memory pitch:                          2147483647 bytes

  Texture alignment:                             256 bytes

  Clock rate:                                    1.48 GHz

  Concurrent copy and execution:                 Yes

  Run time limit on kernels:                     Yes

  Integrated:                                    No

  Support host page-locked memory mapping:       Yes

  Compute mode:                                  Default (multiple host threads can use this device simultaneously)

  Concurrent kernel execution:                   No

  Device has ECC support enabled:                No

  Device is using TCC driver mode:               No

deviceQuery, CUDA Driver = CUDART, CUDA Driver Version = 3.20, CUDA Runtime Version = 3.20, NumDevs = 1, Device = GeForce GTX 285

PASSED

And nvidia-smi shows:

nvidia-smi -a

==============NVSMI LOG==============

Timestamp                       : Thu Nov 11 15:08:03 2010

Driver Version                  : 260.19.14

GPU 0:

        Product Name            : GeForce GTX 285

        PCI Device/Vendor ID    : 5e310de

        PCI Location ID         : 0:3:0

        Display                 : Connected

        Temperature             : 45 C

        Fan Speed               : 40%

        Utilization

            GPU                 : 0%

            Memory              : 1%

Any suggestions?

Thanks,

G

I have now uninstalled the 3.2 driver, toolkit, and SDK and installed the 3.0 versions, which I have been using successfully on another similar machine with a GTX285. Interestingly, the results are basically identical. deviceQuery still shows the card, as does nvidia-smi, but programs still fail with:

Running on...

Device 0: GeForce GTX 285

 Quick Mode

bandwidthTest.cu(600) : cudaSafeCall() Runtime API error : no CUDA-capable device is available.

I have now uninstalled the 3.2 driver, toolkit, and SDK and installed the 3.0 versions, which I have been using successfully on another similar machine with a GTX285. Interestingly, the results are basically identical. deviceQuery still shows the card, as does nvidia-smi, but programs still fail with:

Running on...

Device 0: GeForce GTX 285

 Quick Mode

bandwidthTest.cu(600) : cudaSafeCall() Runtime API error : no CUDA-capable device is available.

This issue was finally solved by updating RHEL and installing driver 260.19.21 and toolkit 3.2.16. Not sure if one or the other or both was needed. Disappointed by lack of response from NVIDIA on this issue, but glad to have it resolved.

This issue was finally solved by updating RHEL and installing driver 260.19.21 and toolkit 3.2.16. Not sure if one or the other or both was needed. Disappointed by lack of response from NVIDIA on this issue, but glad to have it resolved.

With the update to .21 Driver and .16 toolkit. I am seeing these results

cudaSafeCall() Runtime API error : all CUDA-capable devices are busy or unavailable.

Any ideas?

With the update to .21 Driver and .16 toolkit. I am seeing these results

cudaSafeCall() Runtime API error : all CUDA-capable devices are busy or unavailable.

Any ideas?

Same here (hp elitebook 8730w, quadro 2700M, fedora core 13, nvidia proprietary dev driver, .21 .16 toolkit),

one launch and it is over :p

Same here (hp elitebook 8730w, quadro 2700M, fedora core 13, nvidia proprietary dev driver, .21 .16 toolkit),

one launch and it is over :p

I just fought through this error. The following procedure seemed to fix it; I suspect the problem starts when contexts don’t close properly (e.g. a program segfaults, kill -9, etc.).

nvidia-smi -g 0 -c 1

nvidia-smi -g 0 -c 0

You may need to run some cuda code between the commands (I did, but haven’t replicated the problem yet to test whether it was necessary). I suspect the “-c 1” (exclusive mode) has some cleanup for contexts. Switching in and out of “-c 2” had no effect (other than to quickly abort all cuda code).

I just fought through this error. The following procedure seemed to fix it; I suspect the problem starts when contexts don’t close properly (e.g. a program segfaults, kill -9, etc.).

nvidia-smi -g 0 -c 1

nvidia-smi -g 0 -c 0

You may need to run some cuda code between the commands (I did, but haven’t replicated the problem yet to test whether it was necessary). I suspect the “-c 1” (exclusive mode) has some cleanup for contexts. Switching in and out of “-c 2” had no effect (other than to quickly abort all cuda code).

No dice. Changing the mode doesn’t help, trying to run cuda code in between or or not.

I did notice that when I run

nvidia-smi -L

Comes back blank. Is that normal?

I am on Ubuntu 10.04 with a 9600 GT. I got one launch, fully functional. I really don’t want to reinstall the driver every time I boot.

No dice. Changing the mode doesn’t help, trying to run cuda code in between or or not.

I did notice that when I run

nvidia-smi -L

Comes back blank. Is that normal?

I am on Ubuntu 10.04 with a 9600 GT. I got one launch, fully functional. I really don’t want to reinstall the driver every time I boot.

Well, it seemed to fix my card; so I was hoping it was repeatable.

nvidia-smi -L may be blank, but nvidia-smi -a -L should show your card. If it doesn’t say “GPU 0” (unlikely), then you need to change the number after the -g.