Ubuntu20.04 installing cuda8.0 failed,needs help

hi, I got a problem when trying to install cuda8.0 on my Geforce625m GPU,my OS is ubuntu 20.04, it shows:
Toolkit: installation Failed. Using unsupported Compiler.
how to solve this problem?

Cuda 8 needs gcc 5.3 maximum, you’ll have to install that. Remember to switch back to the standard system compiler after usage otherwise the nvidia driver will fail to compile on update.

hi, thanks, I installed gcc 5.3.1 as you instructed , and then I reinstall cuda8.0, it is sucessfully installed but shows not complete,

What does “shows not complete,” mean?

the command line shows the installation is incomplete, and I don’t know whether it affects the running of the installed examples. I would like to give it a try, it seems I had to compile the examples using makefile, can you help me ?

What did you use to install cuda, .run installer or .deb repo?

I use .run to install directly.
BTW, I build the cuda_examples with the makefile and run the result, but it shows an error: helper_cuda.h:1333 code=35(cudaErrorInsufficientDriver) “cudaGetDeviceCount(&device_count)”

This requires that you first install the nvidia driver 390 using Ubuntu’s software&updates application and during cuda install, skip driver installation (answer ‘no’ when it asks for it).
Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

nvidia-bug-report.log.gz (164.9 KB)
hi, I had upload the log file, and now the problem is the Ubuntu’s software&updates application shows only nvidia-340 in the additional drivers, how can I install nvidia 390 , or how to check if my GPU supports driver 390,my GPU is gt625m, I had conviced that it support cuda8.0, so question is how to update the driver?

Your gt625m is supported by the 390 driver which is needed by cuda 8. You indeed have the 340 driver installed, which is too old. Must be some Ubuntu bug it only offers the 340 driver. Please try installing it manually:
sudo apt install nvidia-driver-390
If that doesn’t work, try adding the graphics drivers ppa and then install the 390 driver.

hi, I use apt install 390 but it shows Package ‘nvidia-390’ has no installation candidate, it seems I had to add ppa to install 390 driver, so how to do it?

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update

warning: the ppa is currently in testing, you should be experienced with packaging before you dive in here!and I run these two command , it still throws an error: nvidia-390 has no installation candidate, seems that ppa not working,

Don’t know why it always refers to nvdia-390, did you really run
sudo apt install nvidia-driver-390
Please post the full output.

it works, changing nvidia-390 to nvidia-driver-390 results to success, but another issue occurs: error processing package nvidia-dkms-390, seems this results to nvidia-driver-390 failuremake.log (635.6 KB)

cuda390-report.log (525 Bytes)
I upload the log file , it shows why the driver installation failed. plz check it.

You have set gcc 5.3 as system compiler, that’s why I said to change it back to the standard one, for the driver to compile.
Please use update-alternatives to set gcc and cc back to gcc-9.3

while when I build the examples from cuda8.0 and run it, it shows error: [cuda_driver.h:operator()@81] CUDA Error CUDA_ERROR_UNKNOW: unkown error while calling init(cuinit),and again I reinstall cuda8.0, it shows incomplete installation, the log file is up to date, plz check it.make.log (635.6 KB)

It’s still set to gcc 5.3
Please post the output of
gcc -v
cc -v

make.log (6.7 KB)


hi, I run an cuda based example and the system throws an error, I logged the output into a log file, the screenshot shows an version of gcc