Ubutun 20.04 driver 440 installed but can’t enable nvidia GC

I’m using my Acer Aspire VX15 with a Nvidia GTX 1050 Ti mobile. My goal is to enable cuda and cudnn for using tensorflow (Also I know it is not ideal, but it’s enough for my practicing).

So, After I’ve updated Ubuntu for 20.04, I can’t check nvidia anymore.

I’ve installed drivers, but nvidia-smi returns this error message:

NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

The results of log from bug-report is attached.

In advance, I’m grateful for your help.

nvidia-bug-report.log.gz (157.7 KB)

Hi @batista.cleo

You can re-install nvidia driver with this link. After that it will be work.
https://linuxconfig.org/how-to-install-the-nvidia-drivers-on-ubuntu-20-04-focal-fossa-linux

Hi @TunaHanUlusoy, thanks for your reply.

I’ve installed the Nvidia driver version 390. That’s working now. When I tried 440 or subsequent versions, the gpu wasn’t recognized.

One more detail, I’ve forgot that I’m using kernel 5.6 rather 5.4. I’ve changed it and the problem was solved.

Thanks again.

Glad to hear that @batista.cleo

Good Morning,
Iam very happy to read you thanks for Agree I just would to know about this new opportunity and hope that you will be able to help me
Best Wish,
Lahcene