UFFParser error: Graph error: Cycle graph detected when running mobilenetv2

adit@gibson2:~/ml_model_zoo/20180614_DOD_mobilenet_v2_retina/frozen_model_tensorflow$ ~/Downloads/TensorRT- --uff=frozen_inference_graph.pb.uff --output=FeatureExtractor/MobilenetV2/expanded_conv_16/depthwise/Relu6 --uffInput=image_tensor,3,513,1025
uff: frozen_inference_graph.pb.uff
output: FeatureExtractor/MobilenetV2/expanded_conv_16/depthwise/Relu6
uffInput: image_tensor,3,513,1025
UFFParser: Graph error: Cycle graph detected
Engine could not be created
Engine could not be created

Any idea how to solve this?

Hi, I am also trying to convert a frozen tf model of mobilenet v1 (from https://github.com/yeephycho/tensorflow-face-detection) to tensorrt and have met with the same error:

[TensorRT] ERROR: UFFParser: Graph error: Cycle graph detected
[TensorRT] ERROR: Failed to parse UFF model stream

May I know what could be the problem? Is it an issue of the architecture of the model not being supported in the tensorrt conversion pipeline yet?


Can you please share your command which you are running to convert?

I’ll test and let you know…

Hi,I have met with the same error when I try to convert model form faster_rcnn_resnet101_coco_2018_01_28.

I use the following command to convert model:

convert-to-uff tensorflow -t --input-file frozen_inference_graph.pb -O SecondStagePostprocessor/BatchMultiClassNonMaxSuppression/map/TensorArrayStack/TensorArrayGatherV3 -O SecondStagePostprocessor/BatchMultiClassNonMaxSuppression/map/TensorArrayStack_1/TensorArrayGatherV3 -O add -O SecondStagePostprocessor/ToFloat_1

and use the trtexec to load the uffmode and created Engine as same

Hello all,
I am facing similar issue for SSD Mobilenet V2 model,

Error is,
UFFParser: Graph error: Cycle graph detected

Is there any update on the problem? Whether I can use Custom Layer plugin? Is it possible?

1 Like


Can you tell me how to solve this problem?
“UFFParser: Graph error: Cycle graph detected”

1 Like