Unable to capture IP camera live video stream with GStreamer RTSP protocol on Jetson Nano

Hi,

I am trying to capture live data stream from an IP camera (CP Plus camera, model:CP-UNC-TA21PL3-0360) with Gstreamer using RTSP but I am getting the below error always.

ERROR: from element /GstPipeline:pipeline0/GstURIDecodeBin:uridecodebin0/GstRTSPSrc:source: Could not read from resource.
Additional debug info:
gstrtspsrc.c(5917): gst_rtsp_src_receive_response (): /GstPipeline:pipeline0/GstURIDecodeBin:uridecodebin0/GstRTSPSrc:source:
Could not receive message. (Timeout while waiting for server response)

I used below commands for capturing the data but experiencing the same issue.

  1. gst-launch-1.0 uridecodebin uri=“rtsp://admin:mypassword@:554/cam/realmonitor?channel=1&subtype=1” ! nvoverlaysink

2.gst-launch-1.0 rtspsrc location=“rtsp://admin:mypassword@:554/cam/realmonitor?channel=1&subtype=1” --gst-debug=3 ! rtph264depay ! h264parse ! avdec_h264 ! videoconvert ! autovideosink

What I did:

  • I verified that the IP camera is producing the live data by logging in to its web application.
  • I checked that the camera supports RTSP streaming.
  • I am able to ping the camera from Nano’s terminal.
  • I checked that the VLC is streaming.
  • I tried to disable the firewall using “sudo ufw disable” but there is no such firewall availble in the Nano’s Ubuntu.

Any suggestions/help is appreciated. I all solutions provided in different NVIDIA posts but still the same issue.

Thanks,
RK

Hi,
It looks like URI is invalid. You should run this pipeline without hitting any issue:

gst-launch-1.0 uridecodebin uri="_RTSP_IP_ADDRESS_" ! nvoverlaysink

Suggest you check with camera vendor to get valid URI first.

For CP-UNC-TA21PL3-0360 IP camera, the working RTSP URL is
rtsp://USERNAME:PASSWORD@RTSP_IP_ADDRESS:554/VideoInput/1/mpeg4/1

Ex:
rtsp://admin:admin@192.168.0.210:554/VideoInput/1/mpeg4/1

Thanks for your sharing!