Unable to change Quadro device settings even on administrator account


I have a new Windows 10 laptop with an inbuilt Quadro M2200, which I intend to use for scientific programming.

I am working on an administrator account on the computer, but am still experiencing the following issues:

  • I have tried to change the CUDA Device Driver Mode from WDDM to TCC. It is saying I have insufficient permissions, but this should be possible for accounts with admin privileges.

  • When this was unsuccessful, I tried to disable the WDDM TDR to avoid timeout when running longer kernels, but this also gives an error stating I need to log in as an administrator.

Any advice would be greatly appreciated. Thank you!

I don’t believe you can change a mobile GPU to TCC mode. Not sure why you think this should be possible. It’s not a valid configuration for the Optimus configured laptop, and furthermore I think it is just not supported by NVIDIA on a mobile GPU (Quadro or not). TCC is not supported on all Quadro devices.

You don’t indicate how you attempted to disable the WDDM TDR timeout, but that is a separate issue. You can do it from within VS if you have VS+Nsight VSE loaded. There are instructions in the Nsight VSE documentation. Or you can follow any number of published methods on the web which involve modification of the registry.