Cannot enable TCC mode on RTX 6000A

Hi everyone,

I am having trouble enabling TCC mode on my RTX 6000A GPU. Below is some background and a brief description of the issue. Thanks in advance for your help.

The GPU is installed in a HP Z820 running Windows 10; all the latest drivers are installed and the device is confirmed to be working properly in Device Manager. Note I am using a separate Quadro K4000 for graphics, and no video cables are connected to the 6000A given this GPU will be dedicated to computation tasks only.

I’ve been able to identify both GPU are installed and operating in WDDM mode using the nvidia-smi utility.

I’ve tried to change the operating mode of the 6000A to TCC, using the commands from the nvidia developer website
(Reference Topics :: NVIDIA Nsight VSE Documentation).
Unfortunately this command fails and states “Unable to set driver model for GPU 00000000:41:00.0: Insufficient Permissions Terminating early due to previous errors”.

This error makes no sense to me, given I am operating in Administrator mode and should have full permissions. I’ve also tried rebooting the PC and also with two different administrator accounts but no luck yet.

Regards, Adam

I assume you already double checked that your nvidia-smi invocation is referring to the correct GPU.

I have a fairly similar Win10 setup with dual GPUs of which one is configured to run in TCC mode. However, I did not configure TCC from the administrator account of my machine, but from my normal user account using administrator privileges: I opened a Command Prompt app with the “Run as administrator” option, then ran nvidia-smi from there. You might want to give that approach a try. Beyond that I have no ideas, as I am not very familiar with Windows rights management.

A reboot is required to make the change to TCC take effect, once nvidia-smi lets you configure the GPU for it.

1 Like

I just reconfigured using Command Prompt in Administrator mode, and its all working now!

Thanks for your help with that. It’s much appreciated.