TCC mode not working on Windows11

Hi all,
I’m using a T400 for display and an RTX 6000 Ada for calculations on a Windows11 PC. I want dedicate the RTX 6000 Ada for calculations, so I want to turn on TCC mode. However, when I set it using nvidia-smi and reboot, the device shows a “!” mark and I encounter an error stating ‘This device cannot start (Code10)’ due to insufficient system resources. This error does not occur in the same environment with Windows10. The driver version is “551.52”.
Is there anyone who has experienced the same issue or knows a solution? I have already contacted NVIDIA Customer Care and tried various troubleshooting steps suggested by them, such as reinstalling drivers, updating BIOS to the latest version, and trying different PCIe slots, but the issue remains unresolved. They instructed me to ask here for further assistance.

PC: DELL Precision Tower 7960
CPU: Intel Xeon W5-3435X
Memory: 768GB, DDR5 RDIMM ECC
Storage: SSD 2TB for system, SSD 4TB for data
GPUs: NVIDIA T400 for display, NVIDIA RTX 6000 Ada for calculation(CUDA)

Thanks.

Just a long shot, given you’ve spoken with Nvidia Support, but if you haven’t already tried, you could attempt enabling “PCIe Resizable Base Address Register (BAR)” in the BIOS - it’s off by default.

It’s located in “System Setup Options - Performance Menu”

1 Like

Hi rs277,

Thank you for your reply.
Following your advice, I checked the BIOS settings and found that Resizeable BAR is already enabled by default.
Is there anyone else experiencing a similar issue? This is occurring in a Windows 11 Pro for Workstation, 23H2, x64 environment.
I have also encountered the same phenomenon on a different system (DELL Precision 5860 Tower) when using the RTX A4000 as a compute GPU, leading me to suspect that this might be a problem specific to the Windows 11 drivers.

Thanks.

I have the same problem with an RTXA4000 and RTXA2000 on Windows 11

1 Like

I have same issue, I am using RTXA2000 128G on Windows 11.

1 Like

HI all,

Thank you all for providing information.
How about your environment? Are you still using a DELL Precision? Or is it completely different? I would like to hear NVIDIA’s official stance soon.
I can no longer purchase a PC pre-installed with Windows 10 from DELL, and the computational speed has increased by about 1.3 times compared to having TCC, which is causing me a lot of trouble.

Thanks.

We tried several platforms with the same results:

Mother Board with chipset : Z790
CPU: Intel i5-13400
Memory: 32 GB DDR5
GPU: NVIDIA RTXA2000 and NVIDIA RTXA4000

Mother Board with chipset : Z790
CPU: Intel i7-13700
Memory: 32 GB DDR5
GPU: NVIDIA RTXA2000 and NVIDIA RTXA4000

Mother Board with chipset : H610M-G
CPU: Intel i7-13700
Memory: 32 GB DDR5
GPU: NVIDIA RTXA2000 and NVIDIA RTXA4000

Mother Board with chipset : H610M-G
CPU: Intel i7-14700
Memory: 32 GB DDR5
GPU: NVIDIA RTXA2000 and NVIDIA RTXA4000

1 Like

Hi all,

I undarstood several platforms with same issue.
Are there any individuals who are able to use TCC mode normally with Windows 11 without encountering this issue? If so, I would appreciate a response. I’m interested in knowing whether this is occurring in specific environments or if it’s the same phenomenon for everyone.

1 Like

Hi all,
I could to get a solution to this issue from DELL.
Upon contacting DELL, it appears they were collaborating with NVIDIA to address the problem. They informed us that by turning off the following two items under the BIOS Virtualization section, the issue could be resolved. It seems that the DMA and TCC functions are conflicting:
BIOS > Virtualization Support > Enable Pre-Boot DMA Support
BIOS > Virtualization Support > Enable OS Kernel DMA Support

Then we can set TCC mode on Windows11!