Unable to debug CUDA code

Hi, I learn CUDA and I try to debug CUDA sample on Windows 10 in Visual Studio 2013.
I have GTS 450 GPU with 391.35 display driver. I know that my GPU doesn’t support context switching so I connected my display to motherboard socket and use Intel HD Graphics 630. But when I start debugging, Nsight says that “A cuda context was created on a GPU that is not currently debuggable. Breakpoints will be disabled. Adapter GTS 450”. I tried to reinstall CUDA 8.0 Toolkit, tried to install CUDA 7.5 Toolkit, tried Nsight 5.1, 5.3, 5.5, but every time I got this message. Once when I used CUDA 7.5 and Nsight 5.2 this message wasn’t shown but breakpoints didn’t work.
What CUDA Toolkit and Nsight VIsual Studio Edition should I use?

Switching to the motherboard display doesn’t help, because windows operating system still builds a WDDM driver stack on your GTS 450 GPU. I’m not sure you will be able to debug in this setting. If you switch to linux, you should be able to debug on that GPU.

Okay, if I install second NVIDIA GPU and connect display to it, will I be able to debug CUDA code on my main GPU?