Unable to download torch-tensorrt On Jetson ORIN Jetpack 5.02

As i am trying to install torch-tensorrt using below code;
““pip install torch-tensorrt==1.2.0 -f Releases · pytorch/TensorRT · GitHub””

pip install torch-tensorrt==1.2.0 -f Releases · pytorch/TensorRT · GitHub
Looking in indexes: Simple index, https://pypi.ngc.nvidia.com
Looking in links: Releases · pytorch/TensorRT · GitHub
/home/enord/.local/lib/python3.8/site-packages/pkg_resources/init.py:123: PkgResourcesDeprecationWarning: 1.13.1-unknown is an invalid version and will not be supported in a future release
** warnings.warn(**
/home/enord/.local/lib/python3.8/site-packages/pkg_resources/init.py:123: PkgResourcesDeprecationWarning: 0.23ubuntu1 is an invalid version and will not be supported in a future release
** warnings.warn(**
/home/enord/.local/lib/python3.8/site-packages/pkg_resources/init.py:123: PkgResourcesDeprecationWarning: 0.1.36ubuntu1 is an invalid version and will not be supported in a future release
** warnings.warn(**
/usr/share/python-wheels/urllib3-1.25.8-py2.py3-none-any.whl/urllib3/connectionpool.py:999: InsecureRequestWarning: Unverified HTTPS request is being made to host ‘pypi.ngc.nvidia.com’. Adding certificate verification is strongly advised. See: Advanced Usage - urllib3 2.0.0.dev0 documentation
ERROR: Could not find a version that satisfies the requirement torch-tensorrt==1.2.0 (from versions: 0.0.0, 0.0.0.post1)
ERROR: No matching distribution found for torch-tensorrt==1.2.0

i can import tensorrt, torch2trt

pip3 freeze
/home/enord/.local/lib/python3.8/site-packages/pkg_resources/init.py:123: PkgResourcesDeprecationWarning: 1.13.1-unknown is an invalid version and will not be supported in a future release
warnings.warn(
/home/enord/.local/lib/python3.8/site-packages/pkg_resources/init.py:123: PkgResourcesDeprecationWarning: 0.23ubuntu1 is an invalid version and will not be supported in a future release
warnings.warn(
/home/enord/.local/lib/python3.8/site-packages/pkg_resources/init.py:123: PkgResourcesDeprecationWarning: 0.1.36ubuntu1 is an invalid version and will not be supported in a future release
warnings.warn(
absl-py==1.2.0
actionlib==1.13.2
aiohttp==3.8.1
aiosignal==1.2.0
albumentations==1.2.1
altgraph==0.17.2
angles==1.9.13
apturl==0.5.2
async-timeout==4.0.2
attrs==19.3.0
auto-py-to-exe==2.23.0
autobahn==17.10.1
Automat==0.8.0
bcrypt==3.1.7
blinker==1.4
bondpy==1.8.6
bottle==0.12.23
bottle-websocket==0.2.9
breezy==3.0.2
Brlapi==0.7.0
cachetools==5.2.0
camera-calibration==1.16.0
camera-calibration-parsers==1.12.0
catkin==0.8.10
catkin-pkg==0.5.2
catkin-pkg-modules==0.5.2
catkin-tools==0.9.0
cbor==1.0.0
certifi==2019.11.28
chardet==3.0.4
charset-normalizer==2.1.1
Click==7.0
colorama==0.4.3
configobj==5.0.6
constantly==15.1.0
controller-manager==0.19.5
controller-manager-msgs==0.19.5
cryptography==2.8
cupshelpers==1.0
cv-bridge==1.16.1
cycler==0.10.0
Cython==0.29.32
dbus-python==1.2.16
decorator==4.4.2
defer==1.0.6
defusedxml==0.6.0
Deprecated==1.2.7
diagnostic-analysis==1.11.0
diagnostic-common-diagnostics==1.11.0
diagnostic-updater==1.11.0
distro==1.4.0
distro-info===0.23ubuntu1
docutils==0.16
dulwich==0.19.15
duplicity==0.8.12.0
dynamic-reconfigure==1.7.3
Eel==0.14.0
empy==3.3.2
entrypoints==0.3
fasteners==0.14.1
fastimport==0.9.8
frozenlist==1.3.1
fsspec==2022.8.2
future==0.18.2
gazebo-plugins==2.9.2
gazebo-ros==2.9.2
gencpp==0.6.5
geneus==3.0.0
genlisp==0.4.18
genmsg==0.5.16
gennodejs==2.0.2
genpy==0.6.15
gevent==21.12.0
gevent-websocket==0.10.1
google-auth==2.11.0
google-auth-oauthlib==0.4.6
gpg===1.13.1-unknown
gps-common==0.3.2
graphsurgeon==0.4.6
greenlet==1.1.3
grpcio==1.49.0
httplib2==0.14.0
hyperlink==19.0.0
idna==2.8
image-geometry==1.16.1
imageio==2.21.3
importlib-metadata==4.12.0
incremental==16.10.1
interactive-markers==1.12.0
jetson-stats==4.0.0rc2
Jetson.GPIO==2.0.20
joblib==1.2.0
joint-state-publisher==1.15.1
joint-state-publisher-gui==1.15.1
keyring==18.0.1
kiwisolver==1.0.1
language-selector==0.1
laser-geometry==1.6.7
launchpadlib==1.10.13
lazr.restfulclient==0.14.2
lazr.uri==1.0.3
lockfile==0.12.2
louis==3.12.0
lz4==3.0.2+dfsg
macaroonbakery==1.3.1
Mako==1.1.0
Markdown==3.4.1
MarkupSafe==2.1.1
matplotlib==3.1.2
mavros==1.13.0
message-filters==1.15.14
monotonic==1.5
more-itertools==4.2.0
mpi4py==3.0.3
multidict==6.0.2
nano==0.10.0
netifaces==0.10.4
networkx==2.8.6
nose==1.3.7
numpy==1.17.4
nvidia-pyindex==1.0.9
oauthlib==3.1.0
olefile==0.46
onboard==1.4.1
opencv-python-headless==4.6.0.66
osrf-pycommon==2.0.2
packaging==21.3
pandas==0.25.3
paramiko==2.6.0
pexpect==4.6.0
Pillow==9.2.0
protobuf==3.19.5
psutil==5.5.1
py-ubjson==0.14.0
pyasn1==0.4.2
pyasn1-modules==0.2.1
pycairo==1.16.2
pycrypto==2.6.1
pycryptodomex==3.6.1
pycups==1.9.73
pyDeprecate==0.3.2
pydot==1.4.1
PyGithub==1.43.7
Pygments==2.3.1
PyGObject==3.36.0
PyHamcrest==1.9.0
pyinstaller==5.4.1
pyinstaller-hooks-contrib==2022.10
PyJWT==1.7.1
pymacaroons==0.13.0
PyNaCl==1.3.0
PyOpenGL==3.1.0
pyOpenSSL==19.0.0
pyparsing==2.4.6
pypng==0.0.20
PyQRCode==1.2.1
PyQt5==5.14.1
pyRFC3339==1.1
python-apt==2.0.0+ubuntu0.20.4.8
python-dateutil==2.7.3
python-dbusmock==0.19
python-debian===0.1.36ubuntu1
python-gitlab==2.0.1
python-gnupg==0.4.5
python-qt-binding==0.4.4
python-snappy==0.5.3
pytorch-lightning==1.6.5
PyTrie==0.2
pytz==2019.3
PyWavelets==1.4.1
pyxdg==0.26
PyYAML==6.0
qt-dotgraph==0.4.2
qt-gui==0.4.2
qt-gui-cpp==0.4.2
qt-gui-py-common==0.4.2
qudida==0.0.4
requests==2.22.0
requests-oauthlib==1.3.1
requests-unixsocket==0.2.0
resource-retriever==1.12.7
roman==2.0.0
rosapi==0.11.14
rosbag==1.15.14
rosboost-cfg==1.15.8
rosbridge-library==0.11.14
rosclean==1.15.8
roscreate==1.15.8
rosdep==0.22.1
rosdep-modules==0.22.1
rosdistro==0.9.0
rosdistro-modules==0.9.0
rosgraph==1.15.14
rosinstall==0.7.8
rosinstall-generator==0.1.22
roslaunch==1.15.14
roslib==1.15.8
roslint==0.12.0
roslz4==1.15.14
rosmake==1.15.8
rosmaster==1.15.14
rosmsg==1.15.14
rosnode==1.15.14
rosparam==1.15.14
rospkg==1.4.0
rospkg-modules==1.4.0
rospy==1.15.14
rosservice==1.15.14
rostest==1.15.14
rostopic==1.15.14
rosunit==1.15.8
roswtf==1.15.14
rqt-action==0.4.9
rqt-bag==0.5.1
rqt-bag-plugins==0.5.1
rqt-console==0.4.11
rqt-dep==0.4.12
rqt-graph==0.4.14
rqt-gui==0.5.3
rqt-gui-py==0.5.3
rqt-image-view==0.4.16
rqt-launch==0.4.9
rqt-logger-level==0.4.11
rqt-moveit==0.5.10
rqt-msg==0.4.10
rqt-nav-view==0.5.7
rqt-plot==0.4.13
rqt-pose-view==0.5.11
rqt-publisher==0.4.10
rqt-py-common==0.5.3
rqt-py-console==0.4.10
rqt-reconfigure==0.5.5
rqt-robot-dashboard==0.5.8
rqt-robot-monitor==0.5.14
rqt-robot-steering==0.5.12
rqt-runtime-monitor==0.5.9
rqt-rviz==0.7.0
rqt-service-caller==0.4.10
rqt-shell==0.4.11
rqt-srv==0.4.9
rqt-tf-tree==0.6.3
rqt-top==0.4.10
rqt-topic==0.4.13
rqt-web==0.4.10
rsa==4.9
ruamel.yaml==0.17.21
ruamel.yaml.clib==0.2.6
rviz==1.14.19
scikit-image==0.19.3
scikit-learn==1.1.2
scipy==1.4.1
SecretStorage==2.3.1
sensor-msgs==1.13.1
service-identity==18.1.0
simplejson==3.16.0
sip==4.19.21
six==1.14.0
smach==2.5.0
smach-ros==2.5.0
smclib==1.8.6
swri-transform-util==2.15.2
systemd-python==234
tensorboard==2.10.0
tensorboard-data-server==0.6.1
tensorboard-plugin-wit==1.8.1
tensorrt==8.4.1.5
test-tube==0.7.5
tf==1.13.2
tf-conversions==1.13.2
tf2-geometry-msgs==0.7.5
tf2-kdl==0.7.5
tf2-py==0.7.5
tf2-ros==0.7.5
threadpoolctl==3.1.0
tifffile==2022.8.12
timm==0.6.5
topic-tools==1.15.14
torch==1.11.0
torch2trt==0.4.0
torchmetrics==0.9.3
torchvision==0.13.1
tqdm==4.64.1
Twisted==18.9.0
txaio==2.10.0
typing-extensions==4.3.0
u-msgpack-python==2.1
ubuntu-advantage-tools==27.10
ubuntu-drivers-common==0.0.0
uff==0.6.9
urllib3==1.25.8
urwid==2.0.1
vcstools==0.1.42
wadllib==1.3.3
Werkzeug==2.2.2
whichcraft==0.6.1
wrapt==1.11.2
wsaccel==0.6.2
wstool==0.1.18
xacro==1.14.13
xkit==0.0.0
yarl==1.8.1
zipp==1.0.0
zope.event==4.5.0
zope.interface==4.7.1

Hi,

Based on the release note below:

The release for Jetson is preinstalled in the NGC release.
Thanks.