Unable to flash a backup image into TX2 nor clone the current system.

I made some errors while trying to modify the kernel modules and tried to flash a backup image I made.

I received these key errors: “CPU bootloader is not running on device” and after
[ 0.0151 ] Boot Rom communication
[ 0.0158 ] tegrarcm_v2 --chip 0x18 --rcm rcm_list_signed.xml --skipuid
[ 0.0165 ] Boot Rom communication failed
[ 3.1970 ]
Error: Return value 3
Command tegrarcm_v2 --chip 0x18 --rcm rcm_list_signed.xml --skipuid
Reading board information failed.

I used to be able to flash and clone images pretty easily, but I must have done something very wrong.
I can still boot and use the TX2 except for the errors I was trying to fix. I can run the desktop, surf the net, run ROS etc etc.

I am using TX2 and a native 16.04 Ubuntu on a laptop, connection is direct (not through a USB hub), using the provided USB wire.

You might want to try using a different USB port on your laptop after a reset. Alternatively, have you tried flashing vanilla L4T or JetPack, and see if that’s able to flash successfully? It sounds like you already have the backup image that you could restore later. Beforehand, you could manually backup any extra files you modified/created onboard, since you are still able to boot to desktop.

Was the Jetson freshly put into recovery mode? If you run two operations on a Jetson in recovery mode, then the second operation will probably not be valid, e.g., you can’t clone and flash (or clone twice or flash twice) without restarting the Jetson in recovery mode just before each operation. Running any commands which talk to the Jetson while it is in recovery mode may invalidate the second command unless you restart recovery mode.

Whats the correct method of getting the TX2 out of recovery mode? I simply hold down the power button for 10 seconds.

I doubt I am in two sessions cause I have powereed off and renetered recovery mode. I have fixed it with http://www.jetsonhacks.com/2017/03/25/build-kernel-and-modules-nvidia-jetson-tx2/ to rebuilt the kernel and it’s somewhat working now. I am able to clone the board but I still get the “CPU Bootloader not running on device error” will test out flashing it after.

Hitting the Reset button, or holding down the Power button as you described should do the trick too.

The Jetson actually resets itself out of recovery mode after a successful flashing, if all went well it should automatically boot up to Ubuntu login. If it gets stuck during flashing, it’s often best to manually reset it.

all works now. thanks!