Unable to fully setup UFW firewall

I turn to forum after spending 2 days figuring out why I cant get UFW to work fully.

sudo /usr/share/ufw/check-requirements

results in a

ipv6 rt: FAIL
error was: ip6tables v1.8.4 (legacy): Couldn't load match `rt':No such file or directory

. I tried legacy iptables, newer nftables, rebuilding kernel for nftables support, building the nftables from source, but I suspect I went the wrong way.
Please any ideas?

Please refer to Fix for UFW on Jetpack - Jetson & Embedded Systems / Jetson Nano - NVIDIA Developer Forums to see if can help. Thanks

I will also add that the error message is saying that the kernel configuration does not have that feature (which could be added, perhaps via module). The gist is downloading the kernel source, configuring to exactly match the current running system (including “CONFIG_LOCALVERSION”), followed by using a configuration editor (such as menuconfig or nconfig) to add that feature. Building, and then copying the kernel module to the correct place.

Worked thanks both! :)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.